Error -2147467259 occurs during Commerce Server 2000 or 2002 installation (307940)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q307940

SYMPTOMS

When you attempt to install Commerce Server 2000 or Commerce Server 2002 in a single server configuration, you may receive an error message that is similar to the following if the server does not have a valid IP address (for example, 169.254.*.*):
Commerce Server 2000 WARNING: A failure occurred
in CA_PRED_InstantiateResource() on
d:\cs40\private\cs40\setup\ca_dll\predictor.cpp:50.
The error code is -2147467259, and the description is:
Unspecified error
If you click OK, the Setup program continues with an error message that is similar to the following:
Commerce Server 2000 WARNING: A failure occurred
in CA_DML_InstantiateResource() on
d:\cs40\private\cs40\setup\ca_dll\dml.cpp:156. The
error code is -2147467259, and the description is:
Unspecified error
If you click OK, the Setup program appears to continue and complete.

The Microsoft Windows event logs may also report errors that are similar to the following in the application event log:
Event ID:1000
Source: MsiInstaller
Description:
Product: Commerce Server 2000 -- Commerce Server 2000 WARNING: A failure occurred in CA_PRED_InstantiateResource() on d:\cs40\private\cs40\setup\ca_dll\predictor.cpp:50. The error code is -2147467259, and the description is: Unspecified error
Event ID:1000
Source: MsiInstaller
Description:
Product: Commerce Server 2000 -- Commerce Server 2000 WARNING: A failure occurred in CA_DML_InstantiateResource() on d:\cs40\private\cs40\setup\ca_dll\dml.cpp:156. The error code is -2147467259, and the description is: Unspecified error
Event ID: 257
Source: Commerce Server Direct Mailer
Description:
Error opening or appending to the log file: Exception occurred.
Logging will be disabled at this time.
Event ID: 518
Source: Commerce Server Direct Mailer
Description:
The service was initialized but failed to connect to the database. Please fix the problem and restart the service.
An error message that that is similar to the following may appear in the system event log:
Event ID: 7023
Source: Service Control Manager
Description:
The Commerce Server Direct Mailer service terminated with the following error: Catastrophic failure

CAUSE

Microsoft Commerce Server 2000 or 2002 requires a network card with a valid IP address. You must re-install Commerce Server 2000 or 2002.

RESOLUTION

  1. Assign an IP address to the network card. (use RFC 1918; for example, 192.168.1.1)
  2. Connect the server to the network and attain a valid IP address from a DHCP server.
  3. Re-install Commerce Server 2000 or 2002.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to Reproduce This Behavior

  1. Remove any IP that is bound to the network card(s) and/or remove the network cable that is connected to the network card.
  2. Restart the server.
  3. Install Commerce Server 2000 or 2002.

Modification Type:MajorLast Reviewed:11/17/2004
Keywords:kbprb KB307940