PRB: Product Catalog Import Fails if a Category Is a Parent or Child of Itself (307838)



The information in this article applies to:

  • Microsoft Commerce Server 2000 SP1

This article was previously published under Q307838

SYMPTOMS

When you run a Product Catalog Import Data Transformation Services (DTS) task, the task may complete sucessfully but the Product table in the Data Warehouse may be empty. In the event log you see the following 33184 error events:
Commerce Server 2000
Error	33184
Cannot expand the catalog (null) hierarchy       

Commerce Server 2000
Error	33184
Cannot perform ResolveHierarchy       

Commerce Server 2000
Error	33184
Error copying elements to the Parent list       
				

CAUSE

A category is a parent or child of itself.

RESOLUTION

In Query Analyzer, run the following query to find the relationships in which the parent is the same as the child:
SELECT B.CATEGORYNAME , C.DESCRIPTION, C.PRODUCTID  FROM  [catalogname_CATALOGHIERARCHY] A , 
[catalogname_CATALOGPRODUCTS] B, [catalogname_CATALOGPRODUCTS] C  WHERE  A.OID = B.OID  
AND A.CHILD_OID = C.OID  AND A.OID = A.CHILD_OID
				
NOTE: Replace catalogname with the name of the catalog. You can verify the catalog by looking at the list of tables in your Commerce database.

To resolve this problem, run the following command. Replace catalogname with the name of the catalog.
Delete from catalogname_CATALOGHIERARCHY where oid = child_oid	
				

MORE INFORMATION

This problem does not occur if the catalog is created and manipulated with Commerce Server BizDesk.

Modification Type:MajorLast Reviewed:10/18/2002
Keywords:kbprb KB307838