Visio2002: Callouts Are Not Displayed When You Use Guided Update to Update Your Network Diagram (307658)



The information in this article applies to:

  • Microsoft Visio 2002 Professional
  • Microsoft Visio Network Central
  • Microsoft Visio Enterprise Network Tools

This article was previously published under Q307658

SYMPTOMS

In Microsoft Visio, when you attempt to update your network diagram by dragging a device from the Guided Update window to your network diagram or by clicking a device or network in the Guided Update window, you may experience both of the following behaviors:
  • The focus of your network diagram is shifted to the lower-left corner of the drawing page.

    -and-
  • A blank rectangle is displayed instead of the expected yellow callout (ActiveX control) that lists the action options for the network object that you selected.
As a result, you cannot drag a device from the Guided Update window to your network diagram, nor can you apply any of the changes that are listed in the Guided Update window.

CAUSE

This behavior can occur if any of the following conditions are true:
  • Microsoft Visual Basic for Applications (VBA) is not installed on your computer.
  • VBA is installed but the Enable Microsoft Visual Basic for Applications option is turned off.
  • VBA is installed but the installation is damaged.
To use all features in AutoDiscovery and Layout, VBA must be installed and enabled on the computer from which the solution is run. If VBA is not installed and enabled, you cannot perform certain operations. For example, you cannot drag devices from the Guided Update window to your network diagram.

RESOLUTION

To resolve this issue, use one of the following methods, as appropriate to your circumstances.

Method 1: Install Visual Basic for Applications

To install VBA, follow these steps:
  1. Insert your Visio CD-ROM into your computer's CD-ROM or DVD-ROM drive.
  2. Click Start, point to Settings, and then click Control Panel.
  3. Double-click Add/Remove Programs.
  4. In the Currently installed programs list, click Microsoft Visio 2002, and then click Change.
  5. Click Add or Remove Features - Install or remove specific features, and then click Next.
  6. In the Features tree, click the arrow next to Microsoft Visual Basic for Applications, click Run from My Computer, and then click Install.
  7. Click OK in response to the "Microsoft Visio setup completed successfully" message.

Method 2: Enable Visual Basic for Applications

To enable VBA, follow these steps:
  1. Start Visio.
  2. Click Options on the Tools menu, and then click the Advanced tab.
  3. Under Developer settings, click to select the Enable Microsoft Visual Basic for Applications check box, and then click OK.

Method 3: Repair Your Visual Basic for Applications Installation

To repair your VBA installation, follow these steps:
  1. Insert your Visio CD-ROM into your computer's CD-ROM or DVD-ROM drive.
  2. Click Start, point to Settings, and then click Control Panel.
  3. Double-click Add/Remove Programs.
  4. In the Currently installed programs list, click Microsoft Visio 2002, and then click Change.
  5. Click Repair - Restore to original installation state, and then click Next.
  6. Click OK in response to the "Microsoft Visio setup completed successfully" message.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Use the Guided Update feature when you want to view network changes and incorporate them into your network diagrams. After you run Guided Update, the Guided Update window displays a list of components on your network that have changed since the last time you performed a discovery. You can apply the changes that you want to your network diagram, or you can save the changes to a file and apply the changes at another time.

For more information about the Guided Update feature in Microsoft Visio, type guided update in the Ask a question box or the Answer Wizard, and then press ENTER to view the topics.

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbbug kbpending KB307658