Problems Streaming Content with the Windows Media Player (307650)
The information in this article applies to:
- Microsoft Windows Media Player 6.4
- Microsoft Windows Media Player 7
This article was previously published under Q307650 SYMPTOMS
When users attempt to connect to a stream by using the Windows Media Player, they may experience very poor quality throughout the course of the connection. The symptoms include, but are not limited to, the following:
- The Windows Media Player goes into a buffering loop; that is, the buffering percentage may change from 16% to 58%, then to 96%, then to 58%, then to 75%, then to 98%, then to 30%, and so on.
- The Windows Media Player reports a large amount of packet loss.
- The Windows Media Player freezes in a "Buffering", "Waiting", or "Connecting" stage.
CAUSE
This may be caused by some cable or digital subscriber line (DSL) modems that use Network Address Translation (NAT). Some NAT devices do not properly forward UDP packets.
Similar behavior may be caused by personal firewall software.
RESOLUTION
To resolve this problem, make sure that UDP protocol is disabled for the Windows Media Player on the client computer. If UDP protocol is disabled, the player connects to streaming content through TCP or HTTP (if these are enabled on the Windows Media Server).
To disable the UDP protocol, follow these steps in the Windows Media Player:
For Windows Media Player version 7.0 and later:
- On the Tools menu, click Options.
- Click the Network tab.
- Under Protocols, clear UDP.
For Windows Media Player version 6.4:
- On the View menu, click Options.
- Click the Advanced tab.
- Select Streaming Media and click Change.
- Under Protocols, clear UDP.
MORE INFORMATION
NAT allows clients that use private addresses to access the Internet by having the NAT server use its public address or addresses on behalf of the clients. NAT devices usually assign local IP addresses in the 192.168.x.x or 10.x.x.x ranges.
Modification Type: | Major | Last Reviewed: | 11/3/2003 |
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Keywords: | kbpending kbprb KB307650 |
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