Telnet Program Does Not Try Again to Connect to Server That Has Multiple IP Addresses After First IP Address Does Not Work (307131)
The information in this article applies to:
- Microsoft Windows XP Home Edition
- Microsoft Windows XP Professional
- Microsoft Windows XP 64-Bit Edition
This article was previously published under Q307131 SYMPTOMS
When you try to use Telnet to connect to a telnet server that has multiple IP addresses, and the telnet client program cannot connect by using the telnet server's first Internet Protocol (IP) address, the telnet client program does not continue to try to connect.
CAUSE
This behavior can occur because the telnet client program tries to connect to the telnet server only through the first IP address that is returned, which is an IP version 6 address. If the IP version 6 address does not work, the telnet client program does not try to use the subsequent IP version 4 address.
WORKAROUND
To work around this behavior, manually retrieve the telnet server's IP address, and then enter the IP address into the telnet client program:
- Start a command prompt:
- Click Start, and then click Run.
- In the Run box, type cmd, and then click OK.
- At the command prompt, type ping server_name, where server_name is the name of the telnet server, and then press ENTER. Write down the IP address of the telnet server.
- Start the telnet client program, and then type open ip_address, where ip_address is the IP address that the ping command returned. Press ENTER.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 8/6/2002 |
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Keywords: | kbnetwork kbprb KB307131 |
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