UTF-8 Encoded Notification or Approval HTML Mail Does Not Display Correctly in Some Mail Clients (306883)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q306883
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

Recipients who use mail clients that are not Unicode Translation Format-8 (UTF-8) aware may not be able to view notification and approval mail messages.

CAUSE

This problem can occur because the notification and approval mail are sent as Hypertext Markup Language (HTML) mail encoded by UTF-8; therefore, the mail content may not be displayed correctly.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The Japanese version of this fix should have the following file attributes or later:
   Date          Size      File name     Operating System
   ------------------------------------------------------
   13-May-2001   143,360   Install.exe   Windows
				
After the fix is installed, the following files will have the listed attributes or later:
   Version         Size      File name
   -------------------------------------
   10.145.3914.8   163,840   Pkmsubs.dll
				
After you apply this fix, you need to edit the registry to add the EmailContentCharset value.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To add the EmailContentCharset value:
  1. Start Registry Editor (Regedt32.exe).
  2. Locate and click the following key in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SharePoint Portal Server

  3. On the Edit menu, click Add Value, and then add the following registry value:

    Value name: EmailContentCharset
    Data type: REG_SZ
    Value data: iso-2022-jp

  4. Quit Registry Editor.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbbug kbfix KB306883