You receive a "The documentation is not installed" or "MSDN collection does not exist" error message when you try to access Visual Studio .NET Help (306873)
The information in this article applies to:
- Microsoft Visual Studio .NET (2003), Professional Edition
- Microsoft Visual Studio .NET (2002), Professional Edition
- Microsoft Developer Network (MSDN)
This article was previously published under Q306873 SYMPTOMS
If you installed Visual Studio .NET without including the product documentation and then press F1 to view Help from within Visual Studio .NET, an error message appears saying that "the documentation is not installed" or "MSDN collection does not exist. Please reinstall MSDN." This problem occurs even if you have previously installed the MSDN Library that is included with Visual Studio 6.0 or your MSDN subscription.
CAUSE
Visual Studio .NET 2 uses an updated version of HTML Help that is not yet incorporated into the current releases of the MSDN Library. Because of this, the product is not aware of versions of the MSDN Library other than the version included in its own installation.
RESOLUTION
In order to access Help from Visual Studio .NET, run the Maintenance mode of the product installation and add the documentation. To do so, go to Control Panel and start the Add/Remove Programs utility. Next, click the Visual Studio. NET add/remove option, and then select Maintenance mode to add the option to install the documentation.
STATUS
This behavior is by design.
REFERENCES
For more information about the HTML Help viewer and how to program to the viewer, see the MSDN HTML Help Start Page:
Modification Type: | Minor | Last Reviewed: | 1/31/2006 |
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Keywords: | kbtshoot kberrmsg kbvs2005doesnotapply kbvs2005swept kbprb KB306873 kbAudDeveloper |
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