Error Message When You Browse the Web: An Error Has Occurred in the Script on This Page (306831)
The information in this article applies to:
- Microsoft Internet Explorer 5.5 for Windows NT 4.0 SP 1
- Microsoft Internet Explorer 5.5 for Windows Millennium Edition SP 1
- Microsoft Internet Explorer 5.5 for Windows 98 Second Edition SP 1
- Microsoft Internet Explorer 5.5 for Windows 98 SP 1
- Microsoft Internet Explorer 5.5 for Windows 95 SP 1
- Microsoft Internet Explorer 5.5 for Windows 2000 SP 1
- Microsoft Internet Explorer version 6 for Windows XP
- Microsoft Internet Explorer version 6 for Windows Millennium Edition
- Microsoft Internet Explorer version 6 for Windows 2000
- Microsoft Internet Explorer version 6 for Windows NT 4.0
- Microsoft Internet Explorer version 6 for Windows 98 Second Edition
- Microsoft Internet Explorer version 6 for Windows 98
This article was previously published under Q306831 SYMPTOMS
When you are browsing a Web page, you may receive an error message similar to one of the following:
An error has occurred in the script on this page.
Line: line
Char: character
Error: Class not registered
-or-
On the Status Bar, you may receive the following message:
Done, but with error on page
If you double-click the Status Bar message, and then click Show Details, you receive the following error message:
An error has occurred in the script on this page.
Line: line
Char: character
Error: Class not registered
CAUSE
This issue may occur if the Urlmon.dll file is not registered.
RESOLUTION
To resolve this issue, follow these steps:
- Click Start, and then click Run.
- In the Open box, type Regsvr32 urlmon.dll, and then click OK.
- When prompted with the DllRegisterServer in urlmon.dll succeeded message, click OK.
If the issue persists, follow these steps: - Open the Java Virtual Machine. To do so, visit the following Java Web site:
- Close all instances of Internet Explorer.
- Click Start, click Control Panel, and then double-click Internet Options.
- Click the Advanced tab.
- Under Browsing, click to clear the Enable third-party browser extensions (requires restart) check box.
- Restart Internet Explorer.
If the issue persists, follow these steps: - Open Internet Explorer.
- Click Tools, and click Internet Options.
- Click the Advanced tab.
- Under Browsing, click to select the Disable Script Debugging check box.
- Click OK to close all windows, and then restart the computer.
Modification Type: | Major | Last Reviewed: | 5/11/2004 |
---|
Keywords: | kberrmsg kbprb KB306831 |
---|
|