Your computer restarts repeatedly after you install a Windows 2000 hotfix (306774)



The information in this article applies to:

  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Advanced Server SP1

This article was previously published under Q306774

SYMPTOMS

After you install the hotfix that is described in Microsoft Knowledge Base Article 279491, when you try to restart the computer, the computer restarts repeatedly. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

279491 Multiple CardBus devices cannot share IRQs

CAUSE

This problem occurs because of a regression in the update that is described in the "Symptoms" section. This regression causes the Ntdetect.com file to use an algorithm that is not correct. The Ntdetect.com file enumerates the unused devices that are on the computer.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to obtain the latest Windows 2000 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
--------------------------------------------------------------
28-Aug-2001  21:33                     34,772  Ntdetect.com
02-Aug-2001  04:41  5.0.2195.4023      59,120  Pci.sys
22-Aug-2001  18:39  5.0.2195.4218     109,456  Pcmcia.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to install multiple hotfixes by restarting your computer only one time, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to install multiple Windows updates or hotfixes with only one reboot

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the following article number to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 hotfixes


Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbQFE kbbug kbfix kbWin2000PreSP3Fix KB306774 kbAudEndUser kbAudITPRO kbAudOEM