Error Message When You Start Your Computer: Msgsrv32 Caused Segment Not Present Fault in Module Setupx.dll (306618)
The information in this article applies to:
- Microsoft Windows 98 Second Edition
- Microsoft Windows 98
This article was previously published under Q306618 SYMPTOMS
When you start your computer, you may receive the following error message:
MSGSRV32 caused segment not present fault in module SETUPX.DLL
You may then be unable to start your computer in either Safe mode or Normal mode.
CAUSE
This behavior can occur if the Setupx.dll file is damaged.
RESOLUTION
To resolve this issue, start your computer to a command prompt, rename the existing Setupx.dll file, and then extract a new Setupx.dll file from your original Windows 98 CD-ROM to the Windows\System folder. To do this, follow these steps:
- Insert your Microsoft Windows 98 Startup disk in the floppy disk drive of your computer, and then restart your computer.
NOTE: If you do not have a Windows 98 Startup disk, browse to the following article in the Microsoft Knowledge Base:186300 How to Create a Windows 98 Startup Disk from MS-DOS
- When the Windows 98 Startup menu appears, select
Start Computer with CD-ROM Support.
- Make a note of the letter of your CD-ROM drive. For example, E.
- Insert your Windows 98 CD-ROM into your computer's CD-ROM or DVD-ROM drive.
- At the command prompt, type C:, and then press ENTER.
- Type cd \Windows\System, and then press ENTER.
- Type rename setupx.dll setupx.old, and then press ENTER.
- Type A:, and then press ENTER.
- Type ext, and then press ENTER.
- At the Please enter the path to the Windows CAB files (a:) message, type drive:\win98 (where drive is the letter of your CD-ROM drive), and then press ENTER. For example:
NOTE: If you have an OEM installation of Windows, the CAB files may also be located in the following folder:
- At the Please enter the name(s) of the files(s) you want to extract message, type setupx.dll, and then press ENTER.
- At the Please enter the path to extract to ("Enter" for current directory) message, type C:\Windows\System, and then press ENTER.
- At the Is this okay? (y/n) message, type y, and then press ENTER.
- Remove your Windows 98 Startup disk, and then restart the computer.
For additional information about how to extract original Windows files, click the article number below
to view the article in the Microsoft Knowledge Base:
129605 How to Extract Original Compressed Windows Files
Modification Type: | Minor | Last Reviewed: | 12/20/2004 |
---|
Keywords: | kberrmsg kbprb KB306618 |
---|
|