FIX: ODBC application terminates when you press CTRL+ALT+DEL (306579)
The information in this article applies to:
- Microsoft ODBC Driver for Access 4.0, when used with:
- the operating system: Microsoft Windows NT 4.0
- the operating system: Microsoft Windows 2000
This article was previously published under Q306579 SYMPTOMSUsing ODBC to access a datasource through the Microsoft Jet 4.0 ODBC driver, you may see the following behavior. When the application is running, if the user presses CTRL+ALT+DEL to display the Windows NT Security dialog box and then dismisses the dialog box by clicking Cancel, the ODBC application may terminate unexpectedly. This behavior can also occur when the screensaver is activated and then deactivated.
CAUSE
This is caused by a known issue with Microsoft Jet 4.0 versions that are earlier than Service Pack 6. The problem occurs when the Jet engine is unloaded from memory before all its background worker threads have been shut down. With an ODBC application, this can occur if all ODBC environment handles are freed before the application terminates.
WORKAROUND
Do not free all ODBC environment handles in the application until it is time for the application to be unloaded.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This bug was corrected in Microsoft Jet 4.0 Database Engine Service Pack 6 and later.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
239114
How to obtain the latest service pack for the Microsoft Jet 4.0 Database Engine
Modification Type: | Major | Last Reviewed: | 7/28/2004 |
---|
Keywords: | kbBug kbDatabase kbDriver kbJET kbnofix KB306579 kbAudDeveloper |
---|
|