PRB: Migrating a Stand-alone SQL Server to a Clustered SQL Server in an Active Directory Environment (306529)



The information in this article applies to:

  • Microsoft SQL Server, Enterprise Edition 7.0

This article was previously published under Q306529

SYMPTOMS

During the migration of a stand-alone SQL Server 7.0 environment to a clustered environment, the following error message may occur:
The SQL Server binaries could not be updated. Please close all applications including SQL Manager and the Control Panel on both nodes before pressing 'retry'.
After verifying that all applications are closed and clicking Retry, the following error message is displayed:
The cluster group modification failed. The SQL Server Service could not be started. SQL Cluster Service failed.
The Cluster Administrator then shows SQL Server 7.0 in a failed state and the SQL Server Agent 7.0 and the VServer in an offline state.

The System Event log shows the following errors:
The redirector was unable to initialize security context or query context attributes.

-and-

The Microsoft cluster server could not write file C\:DOCUME~1\SQLCLU~1\LOCALS~1\Temp\CLS106.tmp. The disk may be low on diskpace, or some other serious condition exists.
This second error occurs even though there is ample available space on the specified drive.

CAUSE

The errors occur when the stand-alone computer is a member of the Active Directory (AD) and the cluster is built using the same name for the virtual server that existed for the stand-alone server. During the migration, the stand-alone server has been shut down; this leaves an orphan entry in the AD for the computer account.

When the SQL Failover Wizard tries to bring SQL Server 7.0 online, it is a virtual service and generates a new GUID. Active Directory responds with a different GUID for the computer account that already exists. When the Failover wizard tries to communicate with the GUID received from the AD, communication fails because the server is shut down and this is not the cluster partner.

WORKAROUND

To resolve this problem, the migration must be completed using the following steps:
  1. Back up the databases.
  2. Shut the stand-alone server.
  3. Launch Microsoft Management Console (MMC) and open the Active Directory Users and Computers Snap-in.
  4. In the Computers folder, right-click the computer name and click Delete.
  5. Force a synchronization of the domain.
  6. Start the SQL Failover Wizard on the cluster and use the IP address and name of the stand-alone server.
  7. After the wizard completes, reboot the second node of the cluster and bring all the cluster resources online.
  8. Restore the databases as necessary.

Modification Type:MajorLast Reviewed:10/5/2001
Keywords:kbprb KB306529