Cannot Use Caller ID for RAS Authentication When the Call Uses a Japanese Phone Line (306523)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q306523

SYMPTOMS

When you use Japanese phone lines to place a call, and you try to use Caller ID for Remote Access Service (RAS) user authentication, the Caller ID information is not received.

CAUSE

This behavior can occur because in Japan, phone lines send the Caller ID information before the first ring. If Unimodem receives Caller ID information before the first ring, Unimodem does not pass the Caller ID information on.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

When Caller ID information is passed from the Unimodem AT minidriver (Unimdmat.dll) to the Unimodem TAPI Service Provider (Unimdm.tsp), the code path that fills out the Caller ID data structure is not called unless the Caller ID data structure has been allocated. This Caller ID data structure is allocated only after the first ring is received.

Modification Type:MajorLast Reviewed:12/19/2003
Keywords:kbbug kbenv kbfix kbnetwork kbWin2000sp3fix KB306523