Error Message: Tapisrv Caused an Exception 03h in Module Tsp3216l.tsp at ... (306424)



The information in this article applies to:

  • Microsoft Windows 98

This article was previously published under Q306424
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages:

315854 Windows 98 and Windows Me Error Message Resource Center

SYMPTOMS

When you attempt to start a Microsoft Office program, create a new database in Microsoft Access, or connect to the Internet, you may receive an error message similar to one of the following
TAPISRV caused an Exception 03h in module Tsp3216l.tsp at xxxx:xxxxxxxxxx
where xxxx:xxxxxxxxxx is a string of random characters.

-or-
TAPISRV has caused an error in Tsp3216s.dll

TAPISRV will now close

CAUSE

This behavior can occur if one or more of the Telephony application programming interface (TAPI) components is damaged.

RESOLUTION

To resolve this behavior, rename the TAPI files, and then extract new copies of the files from your original Windows 98 CD-ROM to the appropriate folder on your hard disk. To do this, follow these steps.

Rename the Files

  1. Click Start, point to Find, and then click Files or Folders.
  2. In the Named box, type the following:

    tapiini.exe
    tapi.dll
    tapiui.dll
    tapisrv.exe
    tapiupr.exe
    tapi16.exe
    tsp3216l.tsp
    tsp3216s.dll
    tlocmgr.exe
    telephon.cpl
    tcmsetup.exe
    remotesp.tsp
    unimdm.tsp
    unimodem.vxd
    tapi.inf

  3. In the Look In box, click the drive on which Windows is installed (usually drive C), and then click Find Now.
  4. For each file found, right-click the file, and then click Rename.
  5. Rename each file by using the .old extension. For example, rename tapiini.exe to tapiini.old.

Extract the Original Version of the Files

  1. Insert the Windows 98 CD-ROM into your CD or DVD-ROM drive. Press and hold down the SHIFT key as you insert the CD-ROM to prevent the Windows 98 CD-ROM from starting automatically.
  2. On the Start menu, click Run.
  3. In the Open box, type sfc.exe, and then click OK.
  4. In the System File Checker dialog box, click Extract one file from installation disk.
  5. In the Specify the system file you would like to restore box, type the name of the file that you want to extract, for example type tapiini.exe , and then click Start.
  6. In the Restore From box, type the following line, and then click OK.

    drive:\Win98

    where drive is the drive letter of your CD or DVD-ROM drive that contains the Microsoft Windows 98 CD-ROM.

    NOTE: If your computer has an original equipment manufacturer (OEM) installation of Windows 98, the Windows installation files may also be found in the following folder:

    C:\Windows\Options\Cabs

  7. In the Save File In box, type C:\Windows\System, where C is the drive letter of the hard disk in which Windows 98 is installed, and then click OK.
  8. Click OK to the The file has been successfully extracted message.
  9. Repeat step 5 through step 8 to extract the following files.

    NOTE: The Tapi.inf file is the only file in this list that does not reside in the C:\Windows\System folder. When you extract the Tapi.inf file, change the path in the Save File In box to C:\Windows\Inf.

    Tapiini.exe
    Tapi.dll
    Tapiui.dll
    Tapisrv.exe
    Tapiupr.exe
    Tapi16.exe
    Tsp3216l.tsp
    Tsp3216s.dll
    Tlocmgr.exe
    Telephon.cpl
    Tcmsetup.exe
    Remotesp.tsp
    Unimdm.tsp
    Unimodem.vxd
    Tapi.inf

  10. Restart your computer.

MORE INFORMATION

For additional information about how to extract original Windows files, click the article number below to view the article in the Microsoft Knowledge Base:

129605 How to Extract Original Compressed Windows Files

For additional information about the System File Checker Tool in Windows 98, click the article number below to view the article in the Microsoft Knowledge Base:

185836 Description of the System File Checker Tool (Sfc.exe)


Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kberrmsg kbprb KB306424