Microsoft Distributed Transaction Coordinator Does Not Flush Log Records Efficiently (306365)
The information in this article applies to:
- Microsoft COM+ 1.0, when used with:
- the operating system: Microsoft Windows 2000 SP1
- the operating system: Microsoft Windows 2000 SP2
This article was previously published under Q306365 SYMPTOMS
During a Transaction Processing Performance Council (TPC) benchmark test, Microsoft Distributed Transaction Coordinator (MS DTC) spends 50 percent of its time flushing log records to disk. MS DTC also spends approximately 10 percent of its time moving active connection objects from the active list to the free list.
CAUSE
The log manager has a single flush thread to flush log record pages to disk for all transactions. After the page is on the disk, the flush thread notifies all of the transactions whose records have been flushed. This single thread that notifies the transactions does not scale well on high-end enterprise scenarios.
While MS DTC holds a connection object and a spin lock, MS DTC searches the active list of connection objects in a linear fashion and moves this object to a free list.
RESOLUTION
To resolve this problem, obtain Microsoft COM+ hotfix rollup package 18.2.
For additional information, click the article number below
to view the article in the Microsoft Knowledge Base:
317177 INFO: Availability of Windows 2000 Post-Service Pack 2 COM+ Hotfix Rollup Package 18.2
To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.
Modification Type: | Major | Last Reviewed: | 6/5/2003 |
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Keywords: | kbbug kbDTC kbfix kbWin2000PreSP3Fix kbWin2000sp3fix KB306365 |
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