Restart Required Message When You Scan a Device in Device Manager (306185)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q306185
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you uninstall and rescan (scan for hardware changes) a physical or logical disk device in Device Manager, you may receive a message to restart your computer. When you receive this message, you can view disk contents in Windows Explorer. This problem typically occurs when Windows Explorer is open while you uninstall and rescan the new device.

CAUSE

This problem can occur because the shell keeps the handle to the newly-added disk, which prevents the device removal.

When you add a new disk (a critical device), a driver from the critical device database is installed, and then the actual driver is installed by eliminating the stack and rebuilding it. The Windows 2000 shell that is registered for the new device arrival notification receives the device arrival immediately followed by a device removal and then another device arrival. During the critical device driver removal, a time shell keeps the handle to the newly added disk and this prevents the device removal. When this occurs, the device removal does not work and you receive a message that instructs you to restart your computer.

When the shell keeps the handle to the new arrived disk, it runs the auto-play option, opens a new Windows Explorer window, and then the contents of the disk are displayed. If you keep Windows Explorer open while you uninstall and rescan the device, Windows Explorer opens a handle to the newly-disk device and displays the disk content.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English-language version of this fix should have the following file attributes or later:
   Date         Time     Version        Size       File name
   -----------------------------------------------------------
   06-Nov-2001  10:56AM  5.0.3502.4599  2,338,576  Shell32.dll
				
NOTE: To enable this fix, you must add the following entry to the registry:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer
Value: DisableFixedDiskDriveAutorun
Value Type: REG_DWORD
Value Data: 1

This hotfix disables the auto-play option on the new disk devices. To completely resolve this problem, use this hotfix and close Windows Explorer when you uninstall and rescan the devise.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfix kbHardware kbshell kbWin2000PreSP3Fix kbWin2000sp3fix KB306185