PRB: Authentication Errors When You Browse to the Mobile QuickStart Tutorial (306152)



The information in this article applies to:

  • Microsoft Mobile Internet Toolkit (MMIT)

This article was previously published under Q306152

SYMPTOMS

When you browse to the QuickStart samples from the Microsoft Mobile Internet Toolkit, you may receive authentications errors similar to the following:
You are not authorized to view this page

You do not have permission to view this directory or page using the credentials you supplied.
NOTE: This error message varies depending on which mobile device you are using to browse to the QuickStart samples.

CAUSE

This problem can occur for two reasons:
  • By default, the Mobile Internet Toolkit QuickStart tutorial is setup using Integrated Windows Security, also called Windows NT Challenge Response (NTLM). Integrated Windows Security is found in Microsoft Internet Information Server (IIS). Some mobile devices do not support IIS. The tutorial does not require Integrated Windows Security to work, but is initially setup using that security to protect your web server.
  • The mobile device is using a proxy server that does not allow authentication.

RESOLUTION

Resolution for Mobile Devices That Do Not Support Windows Integrated Security

Because some devices do not support Windows Integrated Security, you can configure the Web site to use either Anonymous access or Basic authentication. However, be aware that Anonymous and Basic authentication are not as secure as Windows Integrated Security. Anonymous access does not require a user name or password for devices to browse to a site. Although Basic authentication requires a user name and password, this information is sent over the network in a base-64 encoded format, which can be easily decoded by using a packet sniffer.

For more information on IIS security, refer to the IIS 5.0 documentation at the following Microsoft Web site:

Getting Started with Internet Information Services (IIS)
http://www.microsoft.com/windows2000/en/server/iis/

How to Enable Anonymous or Basic Authentication

  1. From the Windows Start menu, click Administrative Tools, and then click Internet Services Manager.

    If the Administrative Tools program group does not appear, open Control Panel, double-click Administrative Tools, and then double-click Internet Services Manager.
  2. In Internet Services Manager, locate the default Web site in the left pane. Right-click MobileQuickStart, and then click Properties.
  3. On the Directory Security tab, click Edit under Anonymous access and authentication control.
  4. In the Authentication Methods dialog box, clear the Integrated Windows authentication check box, select either the Anonymous access or Basic authentication check box, and then click OK.

    NOTE: If you select the Basic authentication check box, you are prompted with a warning that is important to read. If you want to use this feature, click Yes in the warning dialog box.
  5. Click OK.

Resolution for Mobile Devices That Use a Proxy Server

In many cases, the mobile device is configured to use a proxy server. The proxy server may not allow secure access, which results from Windows Integrated Security or Basic authentication. To resolve this problem, you can enable your site to use Anonymous access.

Alternately, you may be able to bypass the proxy server if the mobile device is on the same network. To bypass a proxy server, refer to your mobile device documentation. For example, to configure Pocket Internet Explorer on the Microsoft Pocket PC so that it bypasses a proxy server, follow these steps:
  1. Turn on your Pocket PC.
  2. From the Start menu, click Internet Explorer.
  3. In Pocket Internet Explorer, click Options on the Tools menu.
  4. On the Connections tab, select the Bypass proxy for local addresses check box, and then click OK.

Modification Type:MajorLast Reviewed:6/13/2002
Keywords:kbCHTMLDevice kbDSupport kbEmulation kbHTMLDevice kbprb kbSecurity kbWMLDevice KB306152