COM+ server application that uses interactive user identity fails to load (305761)
The information in this article applies to:
- Microsoft COM+ 1.0
- Microsoft COM+ 1.5
- Microsoft Transaction Server 2.0
This article was previously published under Q305761 SYMPTOMS
When no user is interactively logged on to the server console, if you try to start a COM+ application remotely (either through a Terminal Server session or from a remote client application), the application may fail with the following error message:
8000401A - "The server process could not be started because the
configured identity is incorrect. Check the username and password."
CAUSE
This problem occurs because the default identity for the application is set as Interactive User. Interactive user refers to the user that is logged on directly to the server console. If no interactive user exists, the application fails when it tries to assume the interactive user's identity.
RESOLUTION
To resolve this problem, change the identity for the server application to run under a particular user. To do this, on the Identity tab of the Application Properties dialog box, click This User. In addition, if it is feasible, you can ensure that a user is interactively logged on to the server console while the application is running.
WORKAROUNDIn Microsoft Windows Server 2003, work around this problem by using the /Console switch to log on to Console0. To do this, follow these steps: - Click Start, click Run, type mstsc /console, and then click OK.
- Log on to the computer.
REFERENCES
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
276407
Rights and permissions needed by the Identity account of an MTS/COM+ package
282073 ASP application fails if no user is logged on to the server
312497 COM+ application under domain account fails intermittently
Modification Type: | Major | Last Reviewed: | 11/16/2005 |
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Keywords: | kbprb KB305761 |
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