"Invalid Page Fault in Module USER.EXE" Error Message After You Install a Scanner (305652)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98

This article was previously published under Q305652
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages:

315854 Windows 98 and Windows Me Error Message Resource Center

SYMPTOMS

When you restart your computer after installing a scanner, you may receive one or more of the following error messages:
MPREXE caused an Invalid Page Fault in module USER.EXE at 0010:000000d7.

MSGSRV32 caused a segment not present fault in module USER.EXE at 0010:000000d7.

ISDBDC caused an Invalid Page Fault in module USER.EXE at 0010:000000d7.

VSHWIN32 caused a segment not present fault in module USER.EXE at 0010:000000d7.

CAUSE

This behavior can occur if both of the following conditions are true:
  • You have a Compaq Presario computer that has a Trident-based display adapter installed.

    -and-
  • You install scanner software that installs Adobe Type Manager (ATM).
This behavior can occur because of an incompatibility between Adobe Type Manager and the Trident display driver.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Update the Compaq Display Driver

Uninstall the Adobe Type Manager program, update the Compaq display driver, and then reinstall the Adobe program. To do this, follow these steps:
  1. Remove Adobe Type Manager:
    1. Start the computer. After the initial Power On Self Test (POST), press and hold down the CTRL key.

      The Microsoft Windows 98 Startup menu appears.
    2. Use the ARROW keys to select Safe mode, and then press ENTER.
    3. On the Windows is running in safe mode message, click OK.
    4. Click Start, point to Programs, point to Adobe, and then click Adobe Type Manager.
    5. On the Settings tab, click Uninstall ATM.
    6. Click Begin Uninstall, and then follow the instructions to completely remove Adobe Type Manager.
    7. Restart Windows normally.
  2. Obtain and install the latest display driver for your Compaq computer. Updated device drivers are available at the following Compaq Web site:
  3. Reinstall the Adobe Type Manager program. If the Adobe programs are included with your scanner (bundled software), you may need to reinstall the scanner software.

Method 2: Edit the Config.sys File

  1. Start the computer. After the initial Power On Self Test (POST), press and hold down the CTRL key.

    The Microsoft Windows 98 Startup menu appears.
  2. Use the ARROW keys to select Safe mode, and then press ENTER.
  3. On the Windows is running in safe mode message, click OK.
  4. Click Start, and then click Run.
  5. In the Open box, type Sysedit, and then click OK.
  6. In the System Configuration Editor, click the C:\CONFIG.SYS window.
  7. Place the insertion point before the following line:
    BUFFERSHIGH=40,4
    					
    NOTE: This line may also appear as the following:
    BUFFERS=40,4
    					
  8. Type REM, and then press SPACEBAR.

    The line should now appear as follows:
    REM BUFFERSHIGH=40,4
    					
  9. On the File menu, click Save.
  10. On the File menu, click Exit.
  11. Restart Windows normally.

MORE INFORMATION

Additional information about this issue is available at the following Adobe Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kb3rdparty kberrmsg kbInvalidPageFault kbprb KB305652