OFF97: Error Messages When You Attempt to Run the Spelling Checker (305492)
The information in this article applies to:
- Microsoft Excel 97 for Windows
- Microsoft Outlook 97
- Microsoft PowerPoint 97 for Windows
- Microsoft Word 97 for Windows
This article was previously published under Q305492 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you attempt to run the spelling checker in any of the Microsoft Office programs listed at the beginning of this article, you may receive one of following error messages:
There is not enough memory or disk space to run the spelling checker.
Word cannot find the spelling file mssp232.dll for English (United States).
Word cannot find the spelling file mssp2_EN.lex for English (United States).
Word cannot open the spelling file C:\Program Files\Common Files\Microsoft Shared\Proof\MSSP2_EN.LEX for English (United States).
Cannot initialize spelling checker.
Cannot read main dictionary.
Error occurred while checking spelling. Could not load the Spell Check Dll.
Could not install main dictionary.
PowerPoint can't load the main spelling dictionary. You should run Setup and reinstall.
CAUSE
This behavior can occur if any of the following conditions are true:
- The MSSP232.DLL or MSSP2_EN.DLL file is absent from your computer.
-or- - The MSSP232.DLL or MSSP2_EN.DLL file has become damaged (corrupted).
-or- - The registry does not point to the correct location of MSSP232.DLL and MSSP2_EN.DLL.
RESOLUTION
To resolve this issue, use one or both of the following methods, as needed, in the order presented.
Method 1: Replace the Damaged or Missing Files
To replace damaged or missing files, follow these steps:
- Use Windows Explorer to locate and then select the following folder:
C:\Program Files\Common Files\Microsoft Shared\Proof - If the MSSP232.DLL and MSSP2_EN.DLL files are present, rename them as MSSP232.OLD and MSSP2_EN.OLD, respectively.
- Locate and open the following folder on your Microsoft Office 97 CD-ROM:
CD-ROM drive:\OS\MSApps\Proof - Copy the MSSP232.DLL and MSSP2_EN.DLL files to the folder that you opened in step 1.
NOTE: If these steps do not resolve the issue, proceed to Method 2.
Method 2: Update Your Registry Settings
To update your registry settings, follow these steps. WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. - Click Start, and then click Run.
- In the Open box, type regedit, and then press ENTER.
- Locate and select the following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Proofing
Tools\Spelling\1033\Normal
- Double-click Dictionary, make sure that its Value data contains the correct path to MSSP2_EN.LEX, and then click OK.
NOTE: The default path is C:\Program Files\Common Files\Microsoft
Shared\Proof\MSSP2_EN.LEX.
- Double-click Engine, make sure that its Value data contains the correct path to MSSP232.DLL, and then click OK.
NOTE: The default path is C:\Program Files\Common Files\Microsoft
Shared\Proof\MSSP232.DLL.
- Close the Registry Editor.
- Restart your computer.
Modification Type: | Minor | Last Reviewed: | 1/6/2006 |
---|
Keywords: | kberrmsg kbprb KB305492 |
---|
|