Visio2000: Error 113, 115, or 116 When You Save a Visio File to a Network Location (305324)



The information in this article applies to:

  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Technical Edition
  • Microsoft Visio 2000 Enterprise Edition

This article was previously published under Q305324
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you attempt to save a Microsoft Visio drawing file to a network drive, you may receive one of the following error messages:
Error 113

Error 115

Error 116
As a result, you cannot save the file to the network location.

CAUSE

This behavior can occur when your network permissions are incompatible with the permissions that Visio requires in order to successfully perform the save operation.

RESOLUTION

To resolve this issue, edit the NetFlags entry for Visio in the Windows registry. To do this, follow these steps.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


  1. Start Visio. If the Welcome to Microsoft Visio dialog box appears, click Cancel.
  2. On the Tools menu, click Options, and then click the Advanced tab.
  3. Under User settings, click to select the Put all settings in Windows registry check box, and then click OK.
  4. Quit Visio.
  5. On the Start menu, click Run.
  6. In the Open box, type regedit, and then click OK.
  7. Locate the following registry key:

    HKEY_CURRENT_USER\Software\Visio\Visio 2000\application

  8. In the right pane of the Registry Editor window, locate and right-click NetFlags.
  9. Click Modify.
  10. In the Value data box, type 3 to change the NetFlags value from 0 to 3.
  11. Click OK, and then quit the Registry Editor.

MORE INFORMATION

For more information about Visio registry settings, please see the Visreg.txt file located in the \Install\bin\Program Files\Visio\DVS folder of your Visio CD-ROM. The Visreg.txt file describes the registry entries that Visio uses to store user settings and application information.

The following is an excerpt from the Visreg.txt file that describes the NetFlags=0 registry entry:
NetFlags=0
----------
Used to resolve an error 113, 115, or 116 when saving files, 
particularly to a network or floppy disk drive. These errors tend to 
occur when a user's network permissions are incompatible with the 
permissions that Visio needs in order to save files.

1      Remove the user's file naming privileges
3      Remove the user's file rename and delete privileges
				

REFERENCES

For additional information about where Visio settings are stored in the Registry, click the article numbers below to view the articles in the Microsoft Knowledge Base:

298435 Visio2000: Where Settings Are Stored in the Registry: Part 1

298426 Visio2000: Where Settings Are Stored in the Registry: Part 2

298434 Visio2000: Where Settings Are Stored in the Registry: Part 3


Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kbprb KB305324