The "Welcome" Logon Screen Does Not Appear (305281)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q305281

SYMPTOMS

On a Windows XP-based computer that is part of a workgroup and has the Fast User Switching feature enabled, the computer may start without displaying the "Welcome" logon screen.

CAUSE

The Guest account is not relevant when Windows determines if there is only one user without a password. If there is only one user registered on the computer, the "Welcome" logon screen is not displayed before the account is logged on. You can use the Fast User Switching feature to gain access to the Guest account.

Note that this behavior occurs only if the user account is part of a workgroup (not a domain) and any of the following conditions exist:
  • No password is configured for the user account.
  • No other users are registered on the computer.

RESOLUTION

To work around this behavior, either add a second user to the computer or create a password for the user account. This prevents the account from being logged on automatically. For additional information about creating user accounts, click the article number below to view the article in the Microsoft Knowledge Base:

279783 HOW TO: Create and Configure User Accounts in Windows XP

STATUS

This behavior is by design.

MORE INFORMATION

After the administrator is automatically logged on, you can switch users to gain access to the Guest account by using the Fast User Switching feature.

For additional information about logging on to Windows XP automatically, click the article number below to view the article in the Microsoft Knowledge Base:

282866 HOW TO: Configure Windows XP to Automatically Log On a User Account


Modification Type:MajorLast Reviewed:10/29/2001
Keywords:kbprb kbui KB305281