USB Keyboard and Mouse May Not Work After Restart or Hibernation (305177)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q305177

SYMPTOMS

When you restart your computer or when you resume a hibernated session on your computer, you may experience the following symptoms:
  • Your Universal Serial Bus (USB) keyboard or mouse may not work until you shut down the computer and then restart it.
  • When you open Device Manager, your USB devices appear under the Unknown Devices branch.
  • The computer adds the following key to the Windows registry:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\USB\VID_0000&PID_0000

CAUSE

This problem can occur if both of the following conditions are true:
  • Legacy USB support is enabled in the basic input/output system (BIOS) settings on your computer.
  • The computer uses an Intel 82801BA I/O Controller Hub (ICH2) chip to control your USB devices.

    To determine if your computer uses an Intel 82801BA I/O Controller Hub (ICH2) chip, expand the Universal Serial Bus controllers branch in Device Manager, and then look for a device that is similar to the following:

    Intel(r) 82801BA USB Universal Host Controller

When you restart your computer or when you resume a hibernated session on your computer, the computer redetects your USB devices, but it does not enumerate them correctly. When this occurs, the USB legacy support settings conflict with the settings that the Universal Host Controller Driver (UHCD) attempts to enforce.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English-language version of this fix should have the following file attributes or later:
   Date         Time   Version        Size    File name
   -------------------------------------------------------
   05-Oct-2001  12:24  5.0.2195.4475  82,080  Halaacpi.dll
   05-Oct-2001  12:24  5.0.2195.4475  66,816  Halacpi.dll
   05-Oct-2001  12:24  5.0.2195.4475  82,976  Halmacpi.dll
				

WORKAROUND

To work around this problem, disable USB legacy support in the BIOS. You may not want to do this if all of the input devices that are attached to the computer are USB. For more information, please refer to the "More Information" section in this article.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

You can typically enable or disable USB legacy support in your computer BIOS settings if your computer BIOS supports this feature. For information about whether your hardware supports USB legacy emulation, view the documentation that is included with your computer or contact your hardware manufacturer. For information about how to contact your hardware manufacturer, click the appropriate article number below to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbHardware kbOSWin2000fix kbWin2000sp3fix KB305177