"Out of License" Error Messages in SBS 2000 Event Logs (305138)



The information in this article applies to:

  • Microsoft Small Business Server 2000

This article was previously published under Q305138

SYMPTOMS

You may receive one or more of the following messages in the Small Business Server (SBS) 2000 event logs.
  • In the System Event log:
    Source: Application Popup
    Event ID: 26
    Description: Application popup: License Warning : Warning: License usage for a product licensed in per server mode is nearing the maximum number of licenses purchased. Consult the Application event log or License Manager from the Administrative Tools folder for more information.

    For more information, see Help and Support Center at http://search.support.microsoft.com/search/?adv=1.
  • In the Application Event log:
    Source: LicenseService
    Event ID: 201
    Description: No license was available for user 'user_name' using product Product.

    Source: LicenseService
    Event ID: 221
    License usage for product Product is nearing maximum number of per server licenses purchased. Consult license manager from the administrative tools folder for more info.
You may also see one or both of the following messages on the server:
License usage for a product licensed in per server mode is nearing the maximum number of licenses purchased. Consult the Application event log or License Manager from the Administrative Tools folder for more information.

License usage for a product in per server mode has exceeded the max. number of licenses purchased an will prohibit further licenses from being granted.
Also, clients may not be able to map drives or access other resources on the server while the server is out of licenses. Clients may also receive error messages such as:
HTTP 403.15 Forbidden: Client Access Licenses Exceeded

No more connections can be made to this remote computer at this time because there are already as many connections as the computer can accept.
Note that Product may be any service that is installed on the server that uses the License service. The most common sources are SMBServer 5.0 and MSExchangeIS.

CAUSE

These error messages can occur if client computers or users take unexpected licenses, or if programs or services log on to the server as a user, which may use more licenses than expected.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes or later.

Small Business Server 2000 Patch: Out of licenses (for Llssrv.exe version earlier than 5.0.2195.3831):
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   17-Aug-2001  15:13  5.0.2195.2980  118,032  Llssrv.exe
   17-Aug-2001  15:28  5.0.2195.2980   46,864  Llsrpc.dll
				

Small Business Server 2000 Patch: Out of licenses (For Llssrv.exe versions 5.0.2195.3831 or higher):
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   05-Sep-2001  17:25  5.0.2195.4295   83,728  Llssrv.exe
   05-Sep-2001  17:31  5.0.2195.3831   48,912  Llsrpc.dll
   05-Sep-2001  17:31  5.0.2195.4264  940,816  Ole32.dll
   05-Sep-2001  17:31  5.0.2195.4266  428,304  Rpcrt4.dll
   05-Sep-2001  17:31  5.0.2195.4264  185,104  Rpcss.dll
				

Please see the "To Install the Update" section of this article to determine which version you should use.

NOTE: Microsoft recommends that you perform a complete verified backup of your server before you install the update.

To Install the Update

  1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  2. Double-click License Logging Service.
  3. Change the Startup Type to Automatic, and then click OK.
  4. Close the Services console.
  5. Verify that Microsoft Windows 2000 Service Pack 2 (SP2) has been installed.
  6. Install the appropriate version of the hotfix that is associated with this article, and then click Continue when you are prompted to reboot the server.

    To determine which version of the hotfix you need, you must verify the current version of Llssrv.exe on your computer:
    1. In Windows Explorer, open the %SystemRoot%\System32 folder.
    2. Right-click the Llssrv.exe file, and then click Properties.
    3. Click the Version tab.
    4. If the version of the Llssrv.exe file is earlier than 5.0.2195.2980, download and install the following patch. Note that if you later install the security update in MS01-041 (Q298012), you may need to install the second version of the hotfix mentioned below. If the version of the Llssrv.exe file is 5.0.2195.3831 or higher, download and install the following patch. Note that version 5.0.2195.3831 of the Llssrv.exe file is installed if the Security patch for MS01-041 (Q298012) has been installed. For additional information about MS01-041, click the article number below to view the article in the Microsoft Knowledge Base:

      298012 Malformed RPC Request Can Cause Service Problems

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:

302099 Windows 2000 Clients Use Multiple Connections When Mapping Drives to a Single Server

298160 Event 201 from Microsoft Exchange in SBS 2000


Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kbHotfixServer kbQFE ATdownload kbbug kbfix kbSysAdmin kbWin2000PreSP3Fix kbWin2000sp3fix KB305138