FIX: Windows Hardware Quality Lab (WHQL) Test Causes Server Appliance Bug Check If Server Appliance Kit Is Installed (305023)



The information in this article applies to:

  • Microsoft Server Appliance Kit (SAK), version 2.0

This article was previously published under Q305023

SYMPTOMS

When you run the Hardware Compatibility Test (HCT) version 10 Driver Verifier on a system that has the Server Appliance Kit (SAK) version 2.0 or 2.01 installed, a bug check is produced with the following error:
Fatal System Error: 0x000000d5

CAUSE

A bug in the Vimdisp.sys and Vmwchdog.sys drivers cause access to memory that has been freed.

RESOLUTION

A hotfix for SAK versions 2.0 and 2.01 has been created to resolve this problem. To obtain the fix, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

This software update package for Microsoft Server Appliance Kit 2.0 and 2.01 contains the following two components:
  • A software update .cab file. This .cab file is intended to be installed by using the software update feature in the Server Appliance Kit Web user interface (UI). Original equipment manufacturers (OEMs) can use this file to provide a hotfix for the end user that can be installed on appliances in the field.
  • This Readme.txt file.
To install the hotfix from a client computer that is using a Web browser and the software update feature, follow the instructions in the Server Appliance Kit Online Help.

To install the hotfix from the device, extract all files from the .cab file, and manually run the command string that is located after the InstallCommand field in the Info.inf file.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix KB305023