MOM Installation Stops, Consolidator Does Not Start, and Some Files Are Filled with Zeros (304671)
The information in this article applies to:
- Microsoft Operations Manager 2000
This article was previously published under Q304671 SYMPTOMS
Your installation of Microsoft Operations Manager 2000 (MOM) may become corrupted and unusable. You may experience data loss, along with the following symptoms:
- The Consolidator may not start.
- The ConfigCache, ConsolidatorResponse.pqf, and ConsolidatorResponse.wkf files may become completely corrupted (filled with zeros).
Stopping and restarting the OnePoint service does not resolve the issue.
CAUSE
This issue can occur if the MOM installation is interrupted, for example, by an operating system crash or by a power failure. The MOM installation may not recover even after the power is restored and the operating system is running again.
WORKAROUND
To work around this issue, try stopping and then restarting the OnePoint service not just once but twice.
The first restart of the OnePoint service repairs the damaged ConfigCache file, but you may still experience the Application Event Log errors that are listed in the MORE INFORMATION section of this article. The second restart of the OnePoint service renames and recreates the ConsolidatorResponse.pqf and ConsolidatorResponse.wkf files. The OnePoint service then continues to run.
However, note that there may still be data loss even after the two damaged files are recreated, specifically loss of events that agents sent while the OnePoint service was not running successfully.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. MORE INFORMATION
Three files that are known to be affected in this situation are:
- C:\Documents and Settings\All Users\Application Data\Mission Critical Software\OnePoint\ConfigGrpName\ConfigCache
- C:\Documents and Settings\All Users\Application Data\Mission Critical Software\OnePoint\ConfigGrpName\ConsolidatorResponse.pqf
- C:\Documents and Settings\All Users\Application Data\Mission Critical Software\OnePoint\ConfigGrpName\ConsolidatorResponse.wkf
The following scenarios discuss the errors that the Application Event Log may record on the MOM server because of damage to these three files.
Scenario 1. Damaged ConfigCache File
When the OnePoint service restarts, the following error messages may be logged:
Event 21255
The agent was unable to open or create the file D:\Documents and Settings\All Users\Application Data\Mission Critical Software\OnePoint\ConfigGrpName\ConfigCache, which it needs in order to cache configuration information. The agent will now shut down.
Error details: Unspecified error
Event 9000
The component with CLSID {10435937-700B-11D2-A6E7-00A0C97148B7} of Configuration Group Name failed to initialize in the allocated time.
Event 9001
The component with CLSID {10435937-700B-11D2-A6E7-00A0C97148B7} of Configuration Group Name failed to start in the allocated time.
Stopping and restarting the OnePoint service resolves this issue.
Scenario 2. Damaged ConsolidatorResponse.wkf File
When the OnePoint service restarts, the following error message may be logged:
Event 21236
The Microsoft Operations Manager 2000 service was unable to create a critical persistent queue file, and will be unable to process any events.
Error details:
%File Name: D:\Documents and Settings\All Users\Application Data\Mission Critical Software\OnePoint\ConfigGrpName\ConsolidatorResponse.pqf
and
D:\Documents and Settings\All Users\Application Data\Mission Critical Software\OnePoint\ConfigGrpName\ConsolidatorResponse.wkf
Error code: Unspecified error
Stopping and restarting the OnePoint service resolves this issue.
Scenario 3. Damaged ConfigCache and ConsolidatorResponse.wkf Files
When the OnePoint service restarts, you receive the same errors as in Scenario 1. The error in Scenario 2 does not occur because the OnePoint service cannot get that far.
Stopping and restarting the OnePoint service does not resolve this issue. You may receive error messages about Events 21236 and Event 9001 but not about Event 9000.
Stopping and restarting the OnePoint service again resolves the issue.
Modification Type: | Minor | Last Reviewed: | 6/13/2005 |
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Keywords: | kbbug kbpending kbsetup KB304671 |
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