SMS: Many 9224 Status Messages from Software Metering Server (304584)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

This article was previously published under Q304584

SYMPTOMS

After you install a Systems Management Server (SMS) 2.0 Software Metering server on Microsoft Windows Server 2003, SMS reports many 9224 status messages that are similar to the following message:
An unknown error was encountered while the application was configuring the software metering tables.

CAUSE

This error message is caused by a conflict with the FoxPro runtime drivers that are included with SMS and those that are included with Windows Server 2003.

Windows Server 2003 includes a stub driver for FoxPro that displays a message that automatically redirects you to the Web site and downloads the latest FoxPro driver. This stub driver is an "earlier version" but has a newer date stamp than the drivers that are included with SMS. Because the SMS installation is running in a hidden context, this message is not seen, and SMS does not copy the correct FoxPro drivers.

WORKAROUND

To work around this problem, install the newest FoxPro driver by visiting the following Microsoft Web site: After the update, SMS should work correctly with no further action needed and the 9224 status messages should stop.

STATUS

Microsoft has confirmed this to be a problem in Systems Management Server version 2.0.

MORE INFORMATION

There are currently no known problems with patching the Software Metering Server (SWM) after an attempted installation, but it is a good idea to perform the FoxPro update before you install the SWM server.

Modification Type:MinorLast Reviewed:1/14/2006
Keywords:kbBug kbpending kbsms200fix KB304584