Exchange databases are not mounted and event logs contain error messages (304166)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server

This article was previously published under Q304166

SYMPTOMS

In the Exchange System Manager, the Microsoft Exchange databases may not be mounted, and Exchange users cannot send or receive e-mail. When you review the event logs of the Exchange computer under this scenario, you may notice one or more of the following error messages:
Event Type: Error
Event Source: Service Control Manager
Event ID: 7032
Description:
The Service Control Manager tried to take a corrective action (Restart the service) after the unexpected termination of the Microsoft Exchange Routing Engine service, but this action failed with the following error: An instance of the service is already running.
Event Type: Error
Event Source: Service Control Manager
Event ID: 7031
Description:
The IIS Admin Service service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 1 milliseconds: Run the configured recovery program.
Event Type: Error
Event Source: Service Control Manager
Event ID: 7031
Description:
The Microsoft Exchange IMAP4 service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 0 milliseconds: No action.
Event Type: Error
Event Source: Service Control Manager
Event ID: 7031
Description:
The Site Server ILS Service service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 0 milliseconds: No action.
Event Type: Error
Event Source: Service Control Manager
Event ID: 7031
Description:
The FTP Publishing Service service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 0 milliseconds: No action.
Event Type: Error
Event Source: Service Control Manager
Event ID: 7031
Description:
The Network News Transport Protocol (NNTP) service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 0 milliseconds: No action.
Event Type: Error
Event Source: Service Control Manager
Event ID: 7031
Description:
The Microsoft Exchange POP3 service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 0 milliseconds: No action.
Event Type: Error
Event Source: Service Control Manager
Event ID: 7031
Description:
The Microsoft Exchange Routing Engine service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.
Event Type: Error
Event Source: Service Control Manager
Event ID: 7031
Description:
The Simple Mail Transport Protocol (SMTP) service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 0 milliseconds: No action.
Event Type: Error
Event Source: Service Control Manager
Event ID: 7031
Description:
The World Wide Web Publishing Service service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 0 milliseconds: No action.

CAUSE

This behavior may occur if either of the following conditions exist:
  • There is a corrupted message in the Simple Mail Transfer Protocol (SMTP) queue. To verify whether this condition exists, follow these steps:
    1. Locate the Queue folder under Exchsrvr\Mailroot\vsi 1.
    2. Rename the Vsi 1 folder.
    3. Create a new Vsi 1 folder.
    4. Restart the IIS Admin service.

      For additional information about how to restart the IIS Admin service, click the following article number to view the article in the Microsoft Knowledge Base:

      317678 HOW TO: Restart Internet Information Services (IIS) on Exchange 2000 Server


      Note The procedure in 317678 is also effective for Exchange 2003.
    5. Restart the Exchange services.
  • The Microsoft Internet Information Services (IIS) metabase becomes corrupted and causes the messaging protocol services to fail.

RESOLUTION

To resolve this issue, use one of the following methods, depending on your situation.

There is a corrupted message in the SMTP queue

Create a new Queue folder. To do so, rename the Queue folder to Queue_old, and then restart the IIS Admin service and the other Exchange services.

Important In a clustered Exchange environment, take the System Attendant Resource offline, restart the IIS Admin service, and then bring all the other Exchange resources online.

The IIS metabase is corrupted

Restore a version of the IIS metabase that is not corrupted. By default, metabase backup files are located in the %SystemRoot%\System32\Inetsrv\MetaBack directory. For additional information about how to restore the IIS metabase, click the following article numbers to view the articles in the Microsoft Knowledge Base:

324277 HOW TO: Create a metabase backup by using IIS 6.0 in Windows Server 2003

302573 HOW TO: Back up and restore IIS

If no IIS metabase backup file exists, you must reinstall IIS on the Exchange computer. To do this, follow these steps:
  1. Open the services item in Control Panel, and then disable all Exchange-related services.
  2. Remove the Microsoft Windows component Internet Information Services (IIS) in Add/Remove Programs.

    Important If this is a clustered server, do not remove the shared components when you remove IIS. Removing shared components on a clustered server will render the cluster unusable.
  3. Remove the Metabase.bin file from the %systemroot%\system32\inetsrv folder. (This action may already be performed by the Windows Component Wizard.)
  4. Restart the server.
  5. Reinstall IIS in Add/Remove Programs.

    Note Make sure that you click Details and enable both the SMTP and NNTP services.
  6. Reinstall any previously installed Windows 2000 service pack. (You can skip this step if you have the service pack files available and the wizard does not prompt you for your Microsoft Windows 2000 CD-ROM.)
  7. Install Exchange again by using the Reinstall option.
  8. Restart the server.
  9. Reinstall any previously installed Exchange service pack.
  10. Mount the databases by using the Exchange System Manager.

MORE INFORMATION

The metabase is where IIS stores its configuration settings. Exchange 2000 uses both IIS and its metabase extensively for Outlook Web Access (OWA) and Routing and for the protocol services such as SMTP, POP3, and Internet Message Access Protocol 4 (IMAP4). It is suggested that you back up the metabase regularly as part of a system state backup or from the IIS administration tool.

Metabase corruption may occur for a variety of reasons, including the following:
  • Antivirus software scanning the %systemroot%\system32\inetsrv\metabase.bin file
  • Iisadmin.exe process stopped or killed unexpectedly
  • Unsupported editing of the metabase
  • Disk corruption or other hardware failures
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

290290 XIMS: Cannot send mail after re-installing the IIS SMTP Service


Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kberrmsg kbprb KB304166 kbAudITPRO