XCON: During GroupWise Migration, an Error Occurs When the GroupWise API Gains Access to an Attachment and an Event ID 4089 Error Message Is Logged (304164)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q304164 SYMPTOMS
When the Exchange 2000 GroupWise Migration Wizard tries to migrate a mailbox, the GroupWise application programming interface (API) that Novell provides may return an error when the GroupWise API gains access to a message attachment in that mailbox. The GroupWise Migration Wizard may log the following event ID 4089 error message:
Event ID: 4089
Source: MSExchangeMig
Type: Error
Category: None
Description: An error occurred accessing an attachment to a message with subject "subject_name" in folder "folder_name" for user "user_name".
This attachment will not be migrated.
CAUSE
This issue may occur for two reasons:
- The GroupWise API call to retrieve the attachment returned an error.
- The GroupWise API call to retrieve the attachment returned the same pointer for the attachment as for the attachment's parent.
In both cases, the attachment is not available. The GroupWise Migration Wizard logs the error message, and then migrates the portion of the message that is available.
The message and its attachments may be available to the GroupWise client, but inaccessible to the GroupWise API. This issue may occur if two or more embedded messages contain attachments. This issue does not affect all embedded message with attachments.
WORKAROUND
To work around this issue, fix the GroupWise mailbox:
- Move the mailbox to another GroupWise post office. This move may rewrite the attachment to a new attachment table and allow the GroupWise Migration Wizard to migrate the attachment.
-or-
- Manually save the attachment that generates the error to a location outside the GroupWise mailbox.
Modification Type: | Major | Last Reviewed: | 7/17/2006 |
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Keywords: | kberrmsg kbprb KB304164 |
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