PIP Administrator Reports Errors When You Connect to a Database (304156)
The information in this article applies to:
- Microsoft BizTalk Server Accelerator for RosettaNet 1.0
This article was previously published under Q304156 SYMPTOMS
When you run the PIP Administrator, you may receive the following message:
PIP Administrator
Run-time error '-2147467259 (80004005)':
A connection to the PIP SDK database could not be
established. Verify that the Accelerator for
RosettaNet system DSN is configured correctly.
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[DBNETLIB][ConnectionOpen (Connect()).]SQL Server
does not exist or access denied.
CAUSE
This error occurs when the system DSN for BTRosettaNet is configured to use a non-existent computer name or to a computer that does not have SQL Server installed.
RESOLUTION
To resolve this problem, make sure that the system DSN for BTRosettaNet is pointing to the correct server and database. You can modify the settings for this system DSN in Control Panel, by double-clinking Administrative Tools, double-clinking Data Sources (ODBC), and then clicking the System DSN tab.
STATUS
This behavior is by design.
MORE INFORMATION
This problem seems to occur as a result of the Windows Installer being launched. If you delete a file or files that were installed with the BizTalk Accelerator for RosettaNet, the next time the Windows Installer runs, it may detect that one of the BizTalk Accelerator for RosettaNet files is missing. When the Windows installer detects a missing file, it may attempt to restore the file. When it is in the process of restoring the file, it may reset the BTRosettaNet DSN settings to use a Server entry of [ComputerName].
Modification Type: | Major | Last Reviewed: | 9/12/2001 |
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Keywords: | kbprb KB304156 |
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