Error message when you try to start the Works Calendar: "Works cannot access one or more files it needs to run the Calendar." (303858)



The information in this article applies to:

  • Microsoft Works 8.0
  • Microsoft Works 7.0
  • Microsoft Works 6
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2004
  • Microsoft Works Suite 2003
  • Microsoft Works Suite 2002
  • Microsoft Works Suite 2001
  • Microsoft Works Suite 2006

This article was previously published under Q303858

SYMPTOMS

When you try to start the Microsoft Works Calendar, you may receive the following error message:
Works cannot access one or more files it needs to run the Calendar. The files may have been renamed, deleted, or moved. Try reinstalling Works, and then starting the program again.

CAUSE

This issue may occur if one of the following conditions is true:
  • The Mswkscal.wcd file is corrupted.
  • The language locale in the Regional and Language Options item in Control Panel is set to one of the following:
    • Bengali (India)
    • Bosnian (Cyrillic)
    • Bosnian (Latin)
    • Croatian (Latin)
    • isiXhosa (South Africa)
    • isiZulu (South Africa)
    • Malayalam (India)
    • Maltese (Malta)
    • Maori (New Zealand)
    • Quechua (Bolivia)
    • Quechua (Ecuador)
    • Quechua (Peru)
    • Sami, Inari (Finland)
    • Sami, Lule (Norway)
    • Sami, Lule (Sweden)
    • Sami, Northern (Finland)
    • Sami, Northern (Norway)
    • Sami, Northern (Sweden)
    • Sami, Skolt (Finland)
    • Sami, Southern (Norway)
    • Sami, Southern (Sweden)
    • Serbian (Cyrillic)
    • Serbian (Latin)
    • Sesotho sa Leboa (South Africa)
    • Setswana (South Africa)
    • Welsh (United Kingdom)

RESOLUTION

To resolve this issue when the Mswkscal.wcd file is corrupted, follow these steps:
  1. Insert the Works CD, and then press SHIFT to prevent the Setup program from starting.

    Note If the Setup program starts, exit the Setup program.
  2. On the desktop, double-click My Computer.
  3. Locate the Mswkscal.wcd file on the Works CD.

    The default location of the Mswkscal.wcd file on the Works CD is as follows:

    drive:\MSWorks\Common\CommApp\mswkscal.wcd

    In this example, drive is the drive letter of the CD drive.
  4. Select the Mswkscal.wcd file, and then press CTRL+C to copy the file to the Clipboard.
  5. Locate the Mswkscal.wcd file on the hard disk drive.

    Depending on the operating system that you are using, the default location of the Mswkscal.wcd file on the hard disk drive is in one of the following locations:
    • C:\Windows\All Users\Application Data\Microsoft\Works\mswkscal.wcd
    • C:\Program Files\Common Files\Microsoft Shared\Works Shared\mswkscal.wcd
    You can also search for the file. To do this, follow these steps:
    1. Click Start, point to Find, and then click Files Or Folders. On Microsoft Windows XP, Microsoft Windows 2000, and Microsoft Windows Millennium Edition (Me), click Start, point to Search, and then click For Files Or Folders.
    2. Type mswkscal.wcd in the Named box, and then click Find Now. On Windows XP, Windows 2000, and Windows Millennium Edition, type mswkscal.wcd in the Search for files or folders named box, and then click Search Now.
  6. When you locate the Mswkscal.wcd file on the hard disk drive, select the file, and then press CTRL+V to replace the file by using the version that you copied from the Works CD.

    Note When you are prompted with the question, "Are sure that you want to over-write the file", click Yes.
  7. Make sure that the new version of the Mswkscal.wcd file is not read-only. Use Microsoft Windows Explorer to locate the file, right-click the file, click Properties, and then click to clear the Read-only check box.
If you still cannot start the Works Calendar, you may have to reinstall Works. To do this, follow these steps.

Remove Works

  1. Click Start, click Settings, and then click Control Panel.

    Note If you are using Windows XP, click Start, and then click Control Panel.
  2. Click Add/Remove, and then remove Works.

Delete folders and then reinstall Works

  1. On the desktop, double-click My Computer.
  2. Locate the following Works folder on the hard disk drive:

    For Windows 95, Windows 98, Windows Millennium Edition:
    C:\Windows\All Users\Application Data\Microsoft\Works

    For Windows 2000 and Windows XP:
    C:\Documents and Settings\All Users\Application Data\Microsoft\Works

  3. Select the folder, and then press DELETE.
  4. Insert the Works CD in the CD drive.
  5. Click Start, click Run, and then type drive:\setup.exe in the Open box. In this example, drive is the drive letter of the CD drive.
  6. Follow the instructions that appear on the screen to reinstall Works.
If the earlier steps have not resolved this issue, manually run the Mdac_typ.exe file, and then install Works.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Insert the Works CD or the Works 2001 CD in the CD drive.
  2. Click Start, point to Find, and then click Files or Folders. Use default steps for Windows 95 and Windows 98 for consumer programs.
  3. In the Named box, type mdac_typ.exe.
  4. In the Look in box, click the drive letter of the CD drive that contains the Works CD.
  5. Click Find Now.
  6. In the list of found files, double-click the Mdac_typ.exe file.
  7. Follow the instructions that appear on the screen to install the MDAC Update.
  8. Restart the computer when you are prompted.
To resolve this issue when the language locale is set to a locale that is listed in the "Cause" section, follow these steps.Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, click Run, type intl.cpl in the Open box, and then click OK.
  2. Click the Regional Options tab.
  3. In the Select an item to match its preferences, or Click Customize to choose your own formats box, click a locale that is not listed in the "Cause" section, and then click OK.

MORE INFORMATION

If you are running Windows 2000 or Windows XP, you may not be able to install the version of MDAC that is included on the Works CD. If you have to update MDAC to resolve this issue, you can download the latest version of MDAC. To do this, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:3/6/2006
Keywords:kberrmsg kbnofix kbprb KB303858 kbAudEndUser kbAudITPRO