Dcpromo Does Not Work If the Credentials Contain a Leading or Trailing Space (303792)
The information in this article applies to:
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Datacenter Server SP2
This article was previously published under Q303792 SYMPTOMS
When you use Dcpromo.exe to create a domain controller, you may receive the following error message:
The operation failed because: Managing the network session with \\FQDN failed "Logon Failure: unknown user name or bad password."
CAUSE
This error message can be caused by leading or trailing spaces in the password for the specified account. The Dcpromo process trims leading and trailing spaces from the password.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name
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19-July-2001 15:21 5.0.2195.3887 607 KB Dcpromo.exe
WORKAROUND
To work around this issue, reset the password so that leading or trailing spaces are not present in the specified password. Or, you can use another account that does not contain these spaces, or type the password without any spaces.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.
Modification Type: | Minor | Last Reviewed: | 9/26/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbDirServices kbfix kbWin2000PreSP3Fix kbWin2000sp3fix KB303792 |
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