Visio2002: "OLE Automation" Error Message When You Attempt to Add Devices to Your Network Diagram (303618)
The information in this article applies to:
- Microsoft Visio 2002 Professional
- Microsoft Visio Network Central
- Microsoft Visio Enterprise Network Tools
This article was previously published under Q303618 SYMPTOMS
When you attempt to use the Add Devices command to add devices to your network diagram, you may receive the following error message in a new Microsoft Visio session window:
%s does not exist. Enter a new file name.
An error has occurred attempting to use the OLE automation interfaces supplied by Visio. Make sure that Visio 5.0 or later has been successfully installed.
When you click OK in response to this message, you receive the following error message:
An error occurred reading the database. Error code = 1005.
A blank Add Devices dialog box is displayed, and you are then unable to add device shapes to your network diagram.
CAUSE
This behavior can occur if all of the following conditions are true:
- You install Microsoft Visio 2000 Enterprise.
-and- - You install Microsoft Visio 2002 and choose to keep the Visio 2000 installation.
-and- - You install Microsoft Visio Enterprise Network tools for Visio 2002.
-and- - You remove Visio 2000 Enterprise.
-and- - You use the Add Devices command in Visio 2002 to add devices to your network diagram based on your AutoDiscovery database.
RESOLUTION
To work around this issue, re-register Visio 2002 after you remove Visio 2000 from your computer's hard disk, and then repair the AutoDiscovery and Layout solution. To do this, follow these steps:
- Click Start, and then click Run.
- In the Open box, type the following line, and then click OK:
- Click Start, point to Settings, and then click
Control Panel.NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
- Double-click Add/Remove Programs.
- In the Currently installed programs list, click Microsoft Visio Network AutoDiscovery and Layout, and then click Change.
- On the Microsoft Visio AutoDiscovery and Layout Maintenance Mode screen, click Repair - Restore to original installation state, and then click Next.
- Click OK in response to the Microsoft Visio AutoDiscovery and Layout setup completed successfully message.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 7/27/2006 |
---|
Keywords: | kbbug kberrmsg kbpending KB303618 |
---|
|