Custom button assignments do not work as expected after you try to change the button assignments for a Microsoft pointing device (303091)



The information in this article applies to:

  • Microsoft Cordless Mouse 1.0
  • Microsoft EasyBall
  • Microsoft IntelliMouse 1.0
  • Microsoft IntelliMouse Explorer
  • Microsoft IntelliMouse with IntelliEye
  • Microsoft IntelliMouse Optical
  • Microsoft Intellimouse Optical Wheel Mouse
  • Microsoft IntelliMouse Pro
  • Microsoft IntelliMouse TrackBall
  • Microsoft Intellimouse Trackball Explorer
  • Microsoft Intellimouse Trackball Optical
  • Microsoft IntelliMouse USB
  • Microsoft IntelliMouse Web
  • Microsoft IntelliPoint software 1.0
  • Microsoft IntelliPoint software 1.1
  • Microsoft IntelliPoint software 2.0
  • Microsoft IntelliPoint software 2.1
  • Microsoft IntelliPoint software 2.2
  • Microsoft IntelliPoint software 3.0
  • Microsoft IntelliPoint software 3.1
  • Microsoft IntelliPoint software 3.2
  • Microsoft IntelliPoint software 4.0
  • Microsoft IntelliPoint software v.5.0
  • Microsoft IntelliPoint Software 5.1
  • Microsoft Laser Mouse 6000
  • Microsoft Optical Mouse by Starck
  • Microsoft Wireless Desktop Version 1.0
  • Microsoft Wireless Intellimouse Explorer USB
  • Microsoft Wireless IntelliMouse Explorer 2.0
  • Microsoft Wireless Notebook Optical Mouse
  • Microsoft Wireless Laser Desktop 6000
  • Microsoft Wireless Laser Desktop 6000 v2.0
  • Microsoft Wireless Laser Mouse 6000
  • Microsoft Wireless Laser Mouse 5000
  • Microsoft Wireless Notebook Laser Mouse 6000
  • Microsoft Wireless Notebook Optical Mouse 4000
  • Microsoft Wireless Optical Desktop 5000
  • Microsoft Wireless Optical Desktop Comfort Edition
  • Microsoft Wireless Optical Mouse 2.0
  • Microsoft Wireless Optical Mouse 5000
  • Microsoft Wireless Optical Mouse 3000
  • Wireless Optical Desktop 3000

This article was previously published under Q303091

SYMPTOMS

After you try to change the button assignments for any one of the Microsoft pointing devices that are listed in the "Applies to" section, you find that all your button assignments are reset to default mode. You cannot change the button assignments for your pointing device.

CAUSE

This issue may occur if the Microsoft IntelliPoint driver file Ipfilter.sys is missing or is corrupted.

RESOLUTION

To resolve this issue, follow these steps.

Start in safe mode

  1. Close all the programs.
  2. Click Start, and then click Shutdown.
  3. Click Restart, and then click OK.
  4. As the system restarts, keep pressing the F8 key to display the Microsoft Windows Startup menu.
  5. Click Safe Mode.
  6. On the desktop, click OK when you receive the safe mode warning message.
Note It typically takes longer to start in safe mode.

Look for ghost devices in Device Manager

  1. Right-click My Computer, click Properties.
  2. Click Device Manager.
  3. Click the QUOTES="YES">View devices by type option.
  4. Expand the list.
  5. Look for any exact duplicates or additional devices that should not be there.

Remove and reinstall the IntelliPoint software

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click Microsoft IntelliPoint, click Add/Remove, click Finish, and then click OK.
  4. Close Control Panel, and then restart the computer.
  5. Reinstall the IntelliPoint software.
If this method does not resolve the issue, follow these steps.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System, click the Hardware tab, and then click Device Manager.
  3. Double-click the Mice and other pointing devices branch to expand it.
  4. Right-click the Microsoft IntelliMouse pointing device, and then click Properties.

    The IntelliMouse pointing device should be listed as follows:

    Microsoft USB IntelliMouse Explorer (IntelliPoint)

  5. Click Update Driver.
  6. In the Upgrade Device Driver Wizard dialog box, click Next.
  7. Click Display a list of the known drivers, and then click Next.
  8. Select the Microsoft mouse driver that ends with (IntelliPoint), and then click Next.
  9. Click Next to confirm that you have selected the correct driver.
  10. Click Finish to complete the installation of the new driver.

Modification Type:MajorLast Reviewed:10/6/2006
Keywords:kbprb KB303091