Error Message: The Current Printer Driver Is Not Compatible with a Policy Enabled on Your Computer That Blocks Windows NT 4.0 or Windows 2000 Kernel Mode Drivers (302991)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q302991

SYMPTOMS

If you try to install Microsoft Windows 2000-based drivers for the Hewlett-Packard PhotoSmart P1000, P1100, P1215, or P1218 printer in Windows XP, you may receive the following error message:
The current printer driver is not compatible with a policy enabled on your computer that blocks Windows NT 4.0 or Windows 2000 kernel mode drivers.

CAUSE

The Windows 2000-based versions of the drivers are not compatible with Windows XP.

RESOLUTION

To resolve this issue, contact Hewlett-Packard to inquire about the availability of an updated driver for your printer that is compatible with Windows XP, or visit the Hewlett-Packard Web site at: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

To work around this issue, use another printer driver that has a similar print engine. The PhotoSmart printers have similar print engines to other Hewlett-Packard printers that are supported with drivers that are included in Windows XP. Using these drivers can provide some functionality for the printer, but not all of the functionality.

The P1000 and P1100 printers are based on the DeskJet 970 printer. The P1215 and P1218 printers are based on the DeskJet 990 printer.
PrinterWindows XP driver to try
HP PhotoSmart P1000 (MFP)HP DeskJet 970
HP PhotoSmart P1100 (MFP)HP DeskJet 970
HP PhotoSmart 1215 (MFP)HP DeskJet 990
HP PhotoSmart 1218 (MFP)HP DeskJet 990

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For information about how to contact Hewlett-Packard, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z


Modification Type:MajorLast Reviewed:12/4/2001
Keywords:kberrmsg kbprb kbprint KB302991