Error Message After You Run Windows 98 Setup: While Initializing Device MSMINI: Windows Protection Error (302956)



The information in this article applies to:

  • Microsoft Windows 98
  • Microsoft Windows 98 Second Edition

This article was previously published under Q302956

SYMPTOMS

When your computer restarts after you run Microsoft Windows 98 Setup, you may receive the following error message:
While Initializing device MSMINI: Windows Protection Error. You need to restart your computer.
You may then be able to start Windows only in Safe mode.

CAUSE

This behavior can occur if the MSMOUSE.VXD virtual device driver is damaged.

RESOLUTION

To resolve this issue, extract a new copy of MSMOUSE.VXD from your original Windows CD-ROM to the Windows\System folder. To do this, follow these steps:
  1. Insert a Windows 98 Startup disk, and then restart your computer to a command prompt. Select Start computer with CD-ROM support.
  2. Note the drive letter assigned to your computer's CD-ROM or DVD-ROM drive.
  3. Insert the Windows 98 CD-ROM into the CD-ROM or DVD-ROM drive.
  4. At the command prompt, type C:, and then press ENTER.
  5. Type CD\Windows\System, and then press ENTER.
  6. Type Rename MSMOUSE.VXD MSMOUSE.OLD, and then press ENTER.
  7. Type Ext, and then press ENTER.
  8. At the Please enter the path to the Windows CAB files (a:) message, type drive:\win98 (where drive is the drive letter that you noted in step 2), and then press ENTER. For example:

    E:\win98 <ENTER>

    NOTE: If you have an OEM installation of Windows, the CAB files may also be located in the following folder:

    C:\WINDOWS\Options\Cabs

  9. At the Please enter the name(s) of the files(s) you want to extract message, type MSMOUSE.VXD, and then press ENTER.
  10. At the Please enter the path to extract to ("Enter" for current directory) message, type C:\Windows\System, and then press ENTER.
  11. At the Is this okay? (y/n) message, type y, and then press ENTER.

    The file is extracted.
  12. Remove the Windows 98 Startup disk, and then restart the computer.

MORE INFORMATION

For additional information about extracting files and troubleshooting Windows startup problems, click the article numbers below to view the articles in the Microsoft Knowledge Base:

129605 How to Extract Original Compressed Windows Files

192926 How to Perform Clean-Boot Troubleshooting for Windows 98


Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kberrmsg kbprb kbWinProtectErr KB302956