Exchange Server 5.5 or Exchange Server 2003 may return truncated message text if the CDO application is running as a service (302935)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 5.5

This article was previously published under Q302935

SYMPTOMS

When you run the Collaboration Data Objects (CDO) application as a Microsoft Windows NT service, if a message body contains double-byte character set (DBCS) characters, the Exchange Server information store may return a truncated message body.

CAUSE

When the CDO application runs as a Windows NT service, CDO uses Unicode text to get the message body. Because the message body is stored as American National Standards Institute (ANSI) text, the Exchange Server information store converts the ANSI text to Unicode text. This problem can occur during the conversation if a DBCS character spans the 16 kilobyte (KB) boundary.

RESOLUTION

Exchange Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Exchange Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Exchange 2000 Server

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

Component: Information store

File nameVersion
Store.exe5.5.2655.37

NOTE: Because of file dependencies, this fix requires Microsoft Exchange Server version 5.5 Service Pack 4.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5.
This problem was first corrected in Microsoft Exchange Server 2003 Service Pack 2.

Modification Type:MajorLast Reviewed:10/20/2005
Keywords:kbHotfixServer kbbug kbExchange550preSP5fix kbfix kbQFE KB302935