Photo Printing Wizard Does Not Print .ico, .emf or .wmf Files (302903)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q302903

SYMPTOMS

The Photo Printing Wizard currently does not support .ico (icon) files, .emf files, or.wmf (Windows metafile) files. If you try to load an .ico, .wmf, or .emf file in the Photo Printing Wizard, the Photo Printing Wizard starts and the second page displays the following message:

Note: Items the wizard cannot print are not displayed.

As a result, you cannot choose .ico, .wmf, or .emf files for printing.

If you use the image preview tool to load one of these types of files and then click Print, the file is loaded into the Photo Printing Wizard. When you attempt to print the file from the image preview tool, you receive the following error message:
The wizard cannot rotate the picture to fit the template correctly. Please convert the file to a standard graphics file type (such as .jpg, .bmp, or .tif) and then try again. Or, if the picture is an unusually large or odd size, rise it, and then try again.

CAUSE

The file types .ino, .emf, and .wmf use white pixels on a transparent background. When these files are rendered to a white (window color) background, no image is drawn. Similarly, when they are printed, they are blank because the white pixels are rendered on a white background.

RESOLUTION

To work around this behavior, load these images in Microsoft Paint (Mspaint.exe) and print them from that program. Paint sets the background to black so the white pixels are viewable and can be printed.

To print the files with Microsoft Paint, follow these steps:
  1. Start Paint.
  2. On the File menu, click Open.
  3. Browse for the .ico, .emf or .wmf file to print.
  4. Open the image in Paint. On the File menu, click Print.
Or, you can change the file association to automatically open a file type. For instructions on how to do this, refer to the "File association" topic in the Help and Support Center.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:1/27/2006
Keywords:kbprb KB302903