Cannot connect with ISP, ping returns error 10091 (302861)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98
  • Microsoft Windows 95

This article was previously published under Q302861
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you attempt to verify your network configuration by using the TCP/IP Ping.exe command-line utility ( Ping Localhost or Ping 127.0.0.1), you may receive the following command-line error message:
PING: transmit failed, error code 10091
You may not be able to connect to (ping) another local computer or another computer on the local network or on the Internet.

CAUSE

This issue can occur if an incorrect Windows Sockets dynamic link library (DLL) file is in the current path or there is more than one simultaneous Windows Sockets implementation. If there is more than one Winsock.dll file on your computer, be sure the first one in the path is appropriate for the network subsystem currently loaded.

This issue can also occur if the Windows Sockets implementation is not currently installed or is configured incorrectly.

RESOLUTION

To resolve this issue, remove and then reinstall your networking components. To do this, follow these steps.

Note You must have your Microsoft Windows CD as well as driver disks for the dial-up adapter (if present) and the network adapter (if present) to complete these steps.

Step 1: Remove Networking Components and Dial-up Networking

For additional information about removing Dial-up Networking and Network components, click the following article number to view the article in the Microsoft Knowledge Base:

181599 How to remove and reinstall dial-up networking and TCP/IP files

Step 2: Remove Network Registry Keys

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. On the taskbar, click Start, and then click Run.
  2. In the Open box, type Scanregw, and then click OK.

    The Windows Registry Checker starts. A message similar to the following appears:

    No errors found.

    The system registry has been backed up already today.
    Would you like to back it up again?

  3. Click Yes. You receive a message stating that backup is complete. Click OK.

    For additional information about how to reinstall TCP/IP on a Windows Millennium Edition computer, click the following article number to view the article in the Microsoft Knowledge Base:

    314465 Troubleshooting Windows: Internet Browsing (Part 3 of 4)



    To remove and reinstall dial-up networking in Windows Millennium Edition, follow these steps:
    1. Remove dial-up networking. To do this:
      1. Click Start , point to Settings , click Control Panel, and then double-click Add/Remove Programs.
      2. Click the Windows Setup tab.
      3. Click Communications, and then click Details.
      4. Click to clear the Dial-Up Networking check box.
      5. When you receive a "Do you want to remove Dial-Up Networking and all components that require it?" message, click Yes.
      6. Click OK two times, and then when you receive a "Do you want to restart your computer now?" message, click Yes.
    2. Reinstall dial-up networking. To do this:
      1. Click Start , point to Settings , click Control Panel, and then double-click Add/Remove Programs.
      2. Click the Windows Setup tab.
      3. Click Communications, and then click Details.
      4. Click OK two times, and then when you receive a "Do you want to restart your computer now?" message, click Yes.
  4. On the taskbar, click Start, and then click Run.
  5. In the Open box, type Regedit, and then click OK.
  6. In Registry Editor, expand the following subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock

  7. Right-click Winsock, and then click Delete on the shortcut menu that appears.

    The following message appears:

    Are you sure you want to delete this key?

  8. Click Yes.
  9. Follow steps 6 through 8 to remove the following registry subkeys:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteAccess\Authentication\SMM_Files
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\AFVXD
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\DHCP
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\Winsock
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\Winsock2

  10. Quit Registry Editor.
  11. Restart the computer.

Step 3: Reinstall Networking Components and Dial-up Networking

For additional information about reinstalling Dial-up Networking and Network components, click the following article number to view the article in the Microsoft Knowledge Base:

181599 How to remove and reinstall dial-up networking and TCP/IP files


Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kberrmsg kbnetwork kbprb KB302861