You receive an "Error 1402. Could not open key: <key name>. System error 1009" error message when you turn on User Profiles in Office XP Setup on Windows 98 or Windows Millennium Edition (302853)



The information in this article applies to:

  • the operating system: Microsoft Windows 98
  • the operating system: Microsoft Windows Millennium Edition
  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer
  • Microsoft Access 2002
  • Microsoft Excel 2002
  • Microsoft FrontPage 2002
  • Microsoft Outlook 2002
  • Microsoft PowerPoint 2002
  • Microsoft Word 2002

This article was previously published under Q302853
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

When you try to install Microsoft Office XP, you receive an error message similar to the following
Error 1402. Could not open key: key name. System error 1009.

Verify that you have sufficient access to that key, or contact your support personnel.
where key name is the name of a key that Office Setup is attempting to write to the Windows registry.

CAUSE

This problem can occur when the following conditions are true:
  • Your computer is running Microsoft Windows 98 or Microsoft Windows Millennium Edition (Me).
  • You turned on User Profiles.
  • There is a problem with the active profile.

WORKAROUND

To work around this problem, use the following procedures in the order that they are presented.

Method 1: Check for registry damage

Microsoft Windows Millennium Edition (Me) and Microsoft Windows 98 include a tool called Registry Checker that can scan your registry for damage (corruption), and, if necessary, restore a backup of the registry. Follow the steps for your operating system to use Registry Checker to scan your registry.

For Windows Me

  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click System Information.
  2. On the Tools menu, click Registry Checker. You may receive the following error message:
    Windows encountered an error accessing the system registry. Windows will restart the computer and repair the system registry for you.
    If you receive this error message, proceed to step 3.

    If you do not receive the error message, you can choose to compact and repair damage to the internal data structure of the system registry by following these steps:
    1. Close all programs that are running.
    2. Click Start and point to Run. In the Open box, type the following and then click OK:

      scanreg /fix

    3. Click Yes to restart the computer.
  3. To restart your computer, click OK.
  4. Follow the remaining steps to restore a good copy of the registry.
  5. Run Office Setup.
If the problem continues, try Method 2 or Method 3.

For Windows 98

  1. Restart the computer, press and hold down CTRL until the Windows 98 Startup menu appears, and then choose Command prompt only.
  2. At the command prompt, type scanreg /fix and then press ENTER.
  3. After the Registry Checker tool finishes repairing the registry, press ENTER.
  4. At the command prompt, type scanreg /opt and then press ENTER.

    NOTE: The /opt command-line switch causes the Registry Checker tool to optimize the registry by removing unused space.
  5. Restart the computer.
  6. Run Office Setup.
If the problem continues, try Method 2 or Method 3.

Method 2: Run Setup under a different profile

If the profile under which you are logged on is damaged (corrupted), you may be able to run Setup under a different user profile. If you log on under a different profile and you are able to install Office, you may need to delete and recreate the problematic profile. Otherwise, you may encounter the same problem when you try to install Office when you are logged back on under that profile.

For more information about removing an existing user profile, click the following article number to view the article in the Microsoft Knowledge Base:

156826 How to disable and delete user profiles

NOTE: If you have profiles turned on and a per-user Start menu, each user who has an existing profile on Windows Me or Windows 98 must run Setup for Office. The only users who do not have to run Setup are those who do not have an existing profile on the computer. When these users log on for the first time, the default user profile is copied into their profile. This default user profile includes all of the registry information and shortcuts that are necessary to start Office programs.

For more information about installing Office XP with user profiles turned on, click the following article number to view the article in the Microsoft Knowledge Base:

302846 An "Application must be installed" error message occurs when you start an Office program

If this method does not resolve the problem, try Method 3.

Method 3: Turn off user profiles before you run setup

  1. On the Start menu, point to Settings, and then click Control Panel. Double-click the Passwords control panel.
  2. Click the User Profiles tab. Click All users of this computer use the same preferences and desktop settings.
  3. Click OK. Restart the computer if you are prompted to do so.
  4. Install Office XP. If the installation of Office is successful, you can turn on user profiles again.
NOTE: If you turn on user profiles again, you may encounter problems running the Office programs.

For more information about the additional steps that you must follow before you run Office XP programs after you turn on user profiles, click the following article numbers to view the articles in the Microsoft Knowledge Base:

234017 Office program shortcuts are missing

302846 An "Application must be installed" error message occurs when you start an Office programs

REFERENCES

For more articles about how to troubleshoot specific errors in Office Setup: For more articles with general information about how to troubleshoot Office errors:

Modification Type:MajorLast Reviewed:8/29/2006
Keywords:kbtshoot kbsetup kberrmsg kbprb KB302853