An "Application must be installed" error message occurs when you start an Office programs (302846)



The information in this article applies to:

  • the operating system: Microsoft Windows 98
  • the operating system: Microsoft Windows Millennium Edition
  • the operating system: Microsoft Windows 95
  • Microsoft Office XP Small Business
  • Microsoft Office XP Students and Teachers
  • Microsoft Access 2002
  • Microsoft FrontPage 2002
  • Microsoft PowerPoint 2002
  • Microsoft Office XP Professional
  • Microsoft Office XP Standard
  • Microsoft Office XP Developer
  • Microsoft Excel 2002
  • Microsoft Outlook 2002
  • Microsoft Word 2002
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Word 2000

This article was previously published under Q302846

SYMPTOMS

When you start an Office program, you receive the following error message.

Office 2000

This application must be installed to run. Please run Setup from the location where you originally installed the application.

Office XP

Office program has not been installed for the current user. Please run setup to install the application.
In this error message, Office program is the Office XP program that you started.

Note You cannot install Office XP on Microsoft Windows 95. All references to Windows 95 in this article apply only to Office 2000.

In addition, when you try to start Office Maintenance Mode Setup in the Add/Remove Programs Control Panel, you receive the following error message:
This action is only valid for products that are currently installed.

CAUSE

These error messages can occur if all of the following conditions are true:
  • You are using Microsoft Windows Millennium Edition (Me), Microsoft Windows 98, or Microsoft Windows 95.
  • You have Profiles turned on.
  • The Start menu is not being shared by all users. This means that the Include Start menu and Program groups in user settings option is selected on the User Profiles tab of the Passwords Properties dialog box.
  • You have not run Setup for Office.

RESOLUTION

To resolve this problem, run Setup for Office.

In this configuration, each user who has an existing profile on Windows Me or Windows 98 must run Setup for Office. The only users who do not have to run Setup are those who do not have an existing profile on the computer. When they log on for the first time, the default user profile is copied into their profile. This default user profile includes all of the registry information and shortcuts necessary to start Office programs.

The first user who runs Setup in the configuration sets the installation location for Office. Any subsequent user cannot change this location, even if the user performs a custom installation. Also, the time required to install Office for second and subsequent users is substantially less than the time required for the first user, assuming that comparable features are installed. This is because Setup does not recopy any files that are already installed.

If you are the second user or a later user who is running Setup in this configuration, you can select a different set of Office features than other users can. If you do, you see a different set of Office shortcuts on the Programs menu. This is because the Start menu is set to per-user. You selected the Include Start menu and Program groups in user settings check box on the User Profiles tab of the Password Properties dialog box.

MORE INFORMATION

If you have Profiles selected, but the Start menu is being shared by all users of the computer, you only have to install Office once. This configuration is selected if the Include Start menu and Program groups in user settings check box is cleared on the User Profiles tab of the Passwords Properties dialog box.

Modification Type:MinorLast Reviewed:4/11/2006
Keywords:kbtshoot kbstartprogram kbprb KB302846