Visio2000: Problems When You Start Visio or Print to a Hewlett Packard Printer (302823)



The information in this article applies to:

  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Technical Edition
  • Microsoft Visio 2000 Enterprise Edition

This article was previously published under Q302823
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

When you attempt to use Microsoft Visio with a Hewlett Packard (HP) printer or plotter as the default printer, you may observe one or more of the following behaviors.
  • When you print from Visio, you may notice the following behaviors:
    • Some text is garbled or missing.
    • An incorrect font is used.
    • Some text is skewed to one side.
  • When you start Visio, you may notice the following behaviors:
    • A "ghost" page is printed automatically.
    • Visio stops responding and the following error message is displayed:
      Visio caused a general protection fault in module GDI32.exe
    • The computer attempts to access drive A.

CAUSE

This behavior occurs when the default printer uses one of the following drivers:
  • HP PCL 5
  • HP PCL 5e
  • HP PCL 6

RESOLUTION

To work around this issue, install a different driver. The drivers for the HP LaserJet III and LaserJet 4 are recommended. You can download the drivers from the following sites.

For HP LaserJet III drivers and downloads, browse to the following Web site: http://www.hp.com/cposupport/swindexes/ljiii_swen.html

For HP LaserJet 4 drivers and downloads, browse to the following Web site: http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?prodNameId=15024&lang=en&cc=us&prodTypeId=18972&prodSeriesId=25484&taskId=135

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.


Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MajorLast Reviewed:8/7/2006
Keywords:kbprb KB302823