Remote Desktop Connection Client Does Not Start Properly (302803)
The information in this article applies to:
- Microsoft Windows XP Professional
This article was previously published under Q302803 SYMPTOMS
When you start the Remote Desktop Connection client, you may find that the window size is the same as the remote desktop size, not full screen as expected; however, the Maximize button indicates the window is in the maximized state. If you click the Maximize button, the window does not enter full-screen mode as expected; instead, the window is restored to a size slightly smaller than the remote desktop size.
CAUSE
This issue can occur if the Default.rdp file is missing or deleted from the My Documents folder.
RESOLUTION
To work around this issue, restart the computer. The Default.rdp file is replaced by Windows File Protection as soon as you restart the Remote Desktop client.
STATUSThis behavior is by design.MORE INFORMATION
When the Default.rdp file is present, you may expect that the initial window state is not maximized, and that if you click the Maximize button, the window will enter full-screen mode.
When your remote desktop window size is less than full screen, if you clicking Maximize, the window returns to the remote desktop size extents but not larger. This behavior prevents the black borders you would see in a full-screen connection when the resolution is set lower than the desktop of the client computer. The feature that enables full-screen mode when you click the Maximize button is by design only if the remote desktop size is exactly equal to the client monitor size on the current monitor. Otherwise, if you click Maximize, the window is restored to the selected resolution.
Modification Type: | Minor | Last Reviewed: | 1/15/2006 |
---|
Keywords: | kbenv kbprb KB302803 |
---|
|