SMS: Advertisement Does Not Run After Distribution Point Is Unavailable (302674)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
- Microsoft Systems Management Server 2.0 SP1
- Microsoft Systems Management Server 2.0 SP2
- Microsoft Systems Management Server 2.0 SP3
This article was previously published under Q302674 SYMPTOMS
After an advertised program does not run because of a network problem in reaching the distribution point, Smsapm32.exe initially schedules and attempts a retry of the program, but later unschedules the program after the Offer Data provider's next polling cycle.
This is a brief summary of events that describes how the problem occurs:
- The System Offer Data provider (Odpsys32.exe) notifies Smsapm32.exe that an advertisement is ready to run.
- Smsapm32.exe attempts to run the advertisement but cannot because of a network error in reaching the distribution point.
- Smsapm32.exe reschedules the advertisement to run again in 10 minutes.
- The next time that Odpsys32.exe performs its work cycle, the Smsapm32.exe thread that it creates unschedules the pending advertisement. You can see this in the Smsapm32.log file by searching on "Unscheduling program."
The number of times that the program attempts to retry the advertisement depends on the Offer Data provider polling interval. If the interval is set to 15 minutes, Smsapm32.exe has time to attempt the retry twice. If the interval is set to the default value of 60 minutes, it retries
approximately 6 times.
CAUSE
When Smsapm32.exe finds pending programs, they are correctly unscheduled. In this situation, the problem occurs if the program does not meet enough of the criteria required to be rescheduled.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
236325 How to Obtain the Latest Systems Management Server 2.0 Service Pack
WORKAROUND
Because the problem occurs after the next polling cycle by the Offer Data provider, the longer this interval is, the more times the program will be attempted by Advertised Program Monitor (APM).
You adjust this interval in the site settings or on each individual client computer. The site-wide setting is the Check for new programs every x minutes value, which is defined on the General tab of the Advertised Program Client agent. If the site-wide settings are allowed to be overridden, you can set the individual client setting in the Advertised Programs Monitor tool in Control Panel. Click System, and then Options to define a custom polling interval that applies to this computer only.
Because APM waits 10 minutes before another attempt, adding 10 minutes to the polling interval equates to another retry attempt by Smsapm32.exe.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Systems Management Server 2.0 Service Pack 4.
Modification Type: | Minor | Last Reviewed: | 10/6/2005 |
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Keywords: | kbHotfixServer kbQFE kbAdvertisement kbBug kbfix kbQFE kbsms200preSP4fix kbSoftwareDist KB302674 |
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