Error Message After You Remove or Install Netware Networks (302589)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98
  • Microsoft Windows 95

This article was previously published under Q302589
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you remove all networking components from the networking control panel and then restart your computer, you may receive the following error message:
Invalid VxD dynamic link call from NWREDIR(04) + 000000D0 to device 0487, Service #6
You may also receive this message after you install a third-party program that adds networking components.

CAUSE

This issue can occur when the Client for Netware Networks (NWREDIR) is not removed correctly or is not installed correctly.

RESOLUTION

To resolve this issue, follow the steps in Method 1. If Method 1 does not resolve the problem, proceed to Method 2.

Method 1

  1. Start the computer in Safe Mode. To do this, press and hold down the CTRL key while the computer starts.
  2. When the boot menu appears, select Safe Mode from the list, and then press ENTER.
  3. When the desktop appears, click Start, point to Settings, and then click Control Panel.
  4. In Control Panel, double-click Network.
  5. In the Network Properties dialog box, click Add.
  6. Select Client.
  7. Click Add.
  8. Click Microsoft, and then click Client for Netware Networks.
  9. Click OK, and then restart the computer when prompted.
  10. When the desktop appears, click Start, point to Settings, and then click Control Panel.
  11. Click Client for Netware Networks, and then click Remove.
  12. Click the Ipx/Spx protocol, and then click Remove.
  13. Click OK, and then restart the computer when prompted.
If this procedure does not resolve the problem, follow the steps in Method 2.

Method 2

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

  1. Start the computer in Safe Mode. To do this, press and hold down the CTRL key while the computer starts.
  2. When the boot menu appears, select Safe Mode from the list, and then press ENTER.
  3. Click Start, and then click Run.
  4. In the Run dialog box, type regedit, and then click OK.
  5. Locate and delete the following registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR

  6. Restart your computer.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kb3rdparty kberrmsg kbprb KB302589