BUG: Database Errors Occur While Running the PIP Administrator (302549)
The information in this article applies to:
- Microsoft BizTalk Server Accelerator for RosettaNet 1.0
This article was previously published under Q302549 SYMPTOMS
When you run the Partner Interface Process (PIP) Administrator, you may receive one of the following error messages:
PIP Administrator
Run-time error '-2147467259 (80004005)':
A connection to the PIP SDK database could not be established. Verify that the Accelerator for RosettaNet system DSN is configured correctly.
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Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection
PIP Administrator
Run-time error '-2147467259 (80004005)':
A connection to the PIP SDK database could not be established. Verify that the Accelerator for RosettaNet system DSN is configured correctly.
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cannot open database requested in login 'databasename'. Login fails.
CAUSE
These errors usually occur as a result of a failed BTSKInstances database setup during the installation of the BizTalk Server Accelerator for RosettaNet. These errors may also occur if the BTSKInstances database becomes corrupted or is deleted.
RESOLUTION
After you set up the BizTalk Server Accelerator for RosettaNet, you must set up the database through the use of a script. The script Create_rn_db.vbs is located on the BizTalk Server Accelerator for RosettaNet CD-ROM.
Steps to Resolve This Problem- Open a command prompt.
- Run the following command:
cscript create_rn_db.vbs /server localhost /dbname BTSKInstances NOTE: Microsoft BizTalk Server Accelerator for RosettaNet must be installed in order for the script to run successfully.
STATUSMicrosoft has confirmed that this is a bug in Microsoft BizTalk Server Accelerator for RosettaNet.
Modification Type: | Major | Last Reviewed: | 9/12/2001 |
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Keywords: | kbbug KB302549 |
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