Printers That Use Ports That Do Not Begin With COM, LPT, or USB Are Not Redirected in a Remote Desktop or Terminal Services Session (302361)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP 64-Bit Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98
  • Microsoft Windows 95
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

This article was previously published under Q302361

SYMPTOMS

When you use Remote Desktop Connection or the Terminal Services Client version 4.0 or 5.0 to connect to another Windows-based computer from a computer that is not running Windows Server 2003, your local printers may not be redirected. As a result, your local printers are not available in the remote desktop or terminal services session.

For example, if your Windows XP-based computer has a multifunction print device using a DOT4 port, it may not be redirected in a remote desktop session to a Windows 2000- or Windows Server 2003-based computer.

CAUSE

This problem occurs because the printer port does not begin with COM, LPT, or USB. By default, printer port names that do not begin with COM, LPT, or USB are only redirected in Windows Server 2003. By default, multifunction print devices may not be redirected unless you are running Windows Server 2003 on your local computer because they use DOT4 ports.

RESOLUTION

To resolve this problem on a computer that is not running Windows Server 2003, force all ports (including DOT4) on the client computer to be filtered for redirection. To do this, add a DWORD value named FilterQueueType to HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR and set its value data to FFFFFFFF.

Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type FilterQueueType, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type FFFFFFFF, and then click OK.
This enables all ports on the client to be redirected.

To work around this problem on a client computer that has a multifunction print device, change the port that the multifunction print device uses from DOT4 to an LPT port.

For example, to configure a multifunction print device to use an LPT port on a Windows XP-based computer, follow these steps:
  1. InControl Panel, openPrinters and Faxes.
  2. Right-click the local printer that is not redirected, and then click Properties.
  3. Click the Ports tab, click an LPT port, and then click Apply.

    The printer should now appear next to that port.
  4. Close the Printer Properties window, and then reconnect by using Remote Desktop.
Important When a multifunction printer is using a standard LPT port instead of the DOT4 port, it loses its multifunction capabilities, such as scanning, faxing, or copying. To regain the multifunction capabilities, the print device must use the DOT4 port.

STATUS

This behavior is by design.

MORE INFORMATION

To view the port name for your printer, or to determine if the device uses a DOT4 port, view the properties of that printer, and then click the Ports(or the Details) tab.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kbenv kbnofix kbprb kbprint KB302361