The Default Windows Logon Interface May Not Appear After Installing Third-Party Program (302346)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

This article was previously published under Q302346
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start your computer after you install a third-party program, the default Windows logon interface may not appear. In Windows XP, the Welcome Screen and the Fast User Switching feature may no longer be available.

CAUSE

This issue can occur if the Graphical Identification and Authentication file (Msgina.dll) is replaced by a third-party program.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To restore the default Windows logon interface, remove the following string value from the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\GinaDLL

After you do so, Windows uses the default Graphical Identification and Authentication file (Msgina.dll).

Modification Type:MajorLast Reviewed:9/23/2003
Keywords:kbenv kbprb kbui KB302346