OLEXP: Error Message: A Connection Failure Has Occurred (Error -23012) (302112)
The information in this article applies to:
- Microsoft Outlook Express 5.0 for Macintosh
- Microsoft Outlook Express 5.02 for Macintosh
This article was previously published under Q302112 For information about the differences between Microsoft Outlook and Microsoft Outlook Express e-mail clients, click the following article number to view the article in the Microsoft Knowledge Base: 257824 OL2000: Differences Between Outlook and Outlook Express SYMPTOMS
When you try to send and receive messages by using Outlook Express, you are able to send messages, but you may receive the following error message when incoming messages are delivered:
Could not retrieve mail from the account <name> A connection failure has occurred (error -23012).
CAUSE
This behavior can occur because of a failed response to the Authenticated Post Office Protocol (APOP) request from Outlook Express to the Post Office Protocol version 3 (POP3) server. The failure occurs because the server is not responding in a manner that is consistent with accepted standards.
RESOLUTION
To resolve this behavior, consult your messaging server administrators about the POP3 server's ability to revert to an unencrypted authentication method when the encrypted method fails.
MORE INFORMATION
Outlook Express uses a the APOP encrypted method of authentication initially when it establishes a session with the POP3 server. This method increases the security for the password guarding against its being intercepted by unauthorized users as clear text over the Internet.
Request For Comment (RFC) 1939 defines the standard for sending encrypted passwords to a POP3 server. According to this standard, there are two possible valid responses. If the server accepts the APOP-encrypted password, known as a challenge, it sends the positive response, usually +OK. If the server is not capable of processing and unencrypting the APOP challenge, it sends a negative response. The most common response is -ERR. At this point, Outlook Express sends the password as clear text.
NOTE: The explanatory text following either of the required responses may vary among server software products.
The captioned error message, specifically that the Transmission Control Protocol/Internet Protocol (TCP/IP) session has been terminated, is returned when the server fails to send the appropriate response to the initial APOP challenge.
Modification Type: | Major | Last Reviewed: | 10/30/2003 |
---|
Keywords: | kbprb KB302112 |
---|
|