Cannot View Program with a Remote Desktop or Terminal Services Connection (302090)



The information in this article applies to:

  • Microsoft Windows XP Professional

This article was previously published under Q302090

SYMPTOMS

When you establish a Remote Desktop or Terminal Services connection to a Windows XP-based computer that is running Terminal Services and that has multiple monitors, you may not see your program if the program was last displayed on a non-primary monitor. When this occurs, you may be able to see a program that is running on the taskbar, but you may be unable to see the program after you restore or maximize it.

CAUSE

This issue can occur because Remote Desktop or Terminal Services connections do not support multiple monitor functionality.

RESOLUTION

To work around this issue, use one of the following methods:

Method 1

Use the ARROW keys to move the program to the primary monitor:
  1. On the taskbar, click the program you want to move.
  2. Press and hold down the ALT key when you press the SPACEBAR to open the Window menu.
  3. Press M to choose the Move command, and then use the ARROW keys to move the program to the primary monitor.
  4. Press ENTER after you move the program to the viewable area.

Method 2

Use Task Manager to quit the program and then start it again:
  1. Press CTRL+SHIFT+ESC to start Task Manager.
  2. On the Applications tab, click the program you want to quit, and then click End Task. Note that you may receive a prompt to save any open files.
  3. Start the program again.

Method 3

Use the File menu to quit the program and then start it again:
  1. On the Taskbar, click the program you want to quit, press ALT, and then press F.
  2. Press X or C to quit the program. Note that you may receive a prompt to save any open files.
  3. Start the program again.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:10/18/2001
Keywords:kbbug kbui KB302090